summaryrefslogtreecommitdiff
path: root/tikzit/configure.ac
diff options
context:
space:
mode:
authorrandomguy3 <randomguy3@7c02a99a-9b00-45e3-bf44-6f3dd7fddb64>2012-02-06 13:57:14 +0000
committerrandomguy3 <randomguy3@7c02a99a-9b00-45e3-bf44-6f3dd7fddb64>2012-02-06 13:57:14 +0000
commitec9d6a41d01c8637f5c92516f319fd508c7fa4a7 (patch)
treefa0887cd3c5ec7d9ae2634c1e1717935cd023803 /tikzit/configure.ac
parenteda7553c0655ab3134742f5114617b2190345ee1 (diff)
GTK: Make it more obvious that there is a potential issue when poppler-glib is not found (but not explicitly disabled)
git-svn-id: https://tikzit.svn.sourceforge.net/svnroot/tikzit/trunk@412 7c02a99a-9b00-45e3-bf44-6f3dd7fddb64
Diffstat (limited to 'tikzit/configure.ac')
-rw-r--r--tikzit/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/tikzit/configure.ac b/tikzit/configure.ac
index 4b9c65f..7e1737f 100644
--- a/tikzit/configure.ac
+++ b/tikzit/configure.ac
@@ -122,4 +122,12 @@ esac
AM_CONDITIONAL([WINDOWS],[test "x$have_msw" = "xyes"])
+AS_IF([test "x$with_poppler" != "xno"],
+ [AS_IF([test "x$have_poppler" != "xyes"],
+ AC_MSG_WARN([poppler-glib was not found; preview support will be disabled])
+ )]
+ )
+
AC_OUTPUT
+
+# vi:sts=2:sw=2:et