summaryrefslogtreecommitdiff
path: root/tikzit/src/Makefile.am
diff options
context:
space:
mode:
authorAlex Merry <alex.merry@cs.ox.ac.uk>2012-12-03 19:02:53 +0000
committerAlex Merry <alex.merry@cs.ox.ac.uk>2012-12-04 11:12:28 +0000
commit94ff07fc9d728d97dde159e0c3e6ab80e29e0855 (patch)
tree2e74ff3d709db87e2e2b27aa501ed46727c054d7 /tikzit/src/Makefile.am
parent0d715a7f17b8e5570b42d7802c502e4aa234a3c1 (diff)
Refactor MainWindow into Application and Window
Basic multiple-window support, but no tools.
Diffstat (limited to 'tikzit/src/Makefile.am')
-rw-r--r--tikzit/src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tikzit/src/Makefile.am b/tikzit/src/Makefile.am
index 7b64bf8..30d9815 100644
--- a/tikzit/src/Makefile.am
+++ b/tikzit/src/Makefile.am
@@ -24,7 +24,8 @@ EDGEDECFILES = ../AH_*.png ../ED_*.png
bin_PROGRAMS = tikzit
BUILT_SOURCES = $(PARSERFILES)
-tikzit_SOURCES = gtk/CairoRenderContext.m \
+tikzit_SOURCES = gtk/Application.m \
+ gtk/CairoRenderContext.m \
gtk/ColorRGB+IntegerListStorage.m \
gtk/ColorRGB+Gtk.m \
gtk/Configuration.m \
@@ -37,7 +38,6 @@ tikzit_SOURCES = gtk/CairoRenderContext.m \
gtk/FileChooserDialog.m \
gtk/GraphInputHandler.m \
gtk/GraphRenderer.m \
- gtk/MainWindow.m \
gtk/Menu.m \
gtk/Node+Render.m \
gtk/NodeStyle+Gtk.m \
@@ -56,6 +56,7 @@ tikzit_SOURCES = gtk/CairoRenderContext.m \
gtk/StylesPane.m \
gtk/TikzDocument.m \
gtk/WidgetSurface.m \
+ gtk/Window.m \
gtk/cairo_helpers.m \
gtk/clipboard.m \
gtk/gtkhelpers.m \