summaryrefslogtreecommitdiff
path: root/tikzit
diff options
context:
space:
mode:
authorAlex Merry <dev@randomguy3.me.uk>2013-10-11 15:19:00 +0100
committerAlex Merry <dev@randomguy3.me.uk>2013-10-11 15:24:37 +0100
commitf054e040a12df4160c632039289b925b251fc81d (patch)
tree4d66a949a381811e81ecb3cf4db53bcd26056d4f /tikzit
parenteb56a2ca0faf7a0e7b8da2f149a9d88783314d82 (diff)
Fix rule dependencies for lexer/parser generation
Previously, if common/tikzparser.m existed but common/tikzparser.h did not, bison would not be re-run, and the build would fail elsewhere with an error about not finding tikzparser.h. The same would be true of the tikzlexer files. Issue #15
Diffstat (limited to 'tikzit')
-rw-r--r--tikzit/src/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/tikzit/src/Makefile.am b/tikzit/src/Makefile.am
index 2f9ac95..ffd05bf 100644
--- a/tikzit/src/Makefile.am
+++ b/tikzit/src/Makefile.am
@@ -124,12 +124,14 @@ tikzit_LDADD = tikzit.res
CLEANFILES = tikzit.res
endif
-common/tikzlexer.m: common/tikzlexer.lm
- $(AM_V_GEN)$(LEX) -o $@ $^
+common/tikzlexer.m common/tikzlexer.h: common/tikzlexer.lm
+ $(AM_V_GEN)$(LEX) -o common/tikzlexer.m $^
+# ordering hack for parallel builds
common/tikzlexer.h: common/tikzlexer.m
-common/tikzparser.m: common/tikzparser.ym
- $(AM_V_GEN)$(YACC) --defines=common/tikzparser.h --output-file=$@ $^
+common/tikzparser.m common/tikzparser.h: common/tikzparser.ym
+ $(AM_V_GEN)$(YACC) --defines=common/tikzparser.h --output-file=common/tikzparser.m $^
+# ordering hack for parallel builds
common/tikzparser.h: common/tikzparser.m
gtk/icondata.m: $(ICONFILES)