summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules5
3 files changed, 15 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b12ca78..c1e384c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+tikzit (2.1.4-3) UNRELEASED; urgency=medium
+
+ * Install style file. Thanks to ael for reporting. (Closes: #947517)
+
+ -- Gard Spreemann <gspr@nonempty.org> Sat, 28 Dec 2019 10:59:44 +0100
+
tikzit (2.1.4-2) unstable; urgency=medium
* Add rules-requires-root: no.
diff --git a/debian/control b/debian/control
index 52783b4..615fd53 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,10 @@ Build-Depends:
libpoppler-dev,
libpoppler-qt5-dev,
qt5-qmake,
- qtbase5-dev
+ qtbase5-dev,
+ tex-common,
+ texlive-base,
+ texlive-binaries
Standards-Version: 4.4.0
Rules-Requires-Root: no
Homepage: https://tikzit.github.io/
diff --git a/debian/rules b/debian/rules
index 355ccdf..68dd482 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,9 +4,14 @@
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export QT_SELECT = qt5
+TEXMFDEBIAN:=$(shell kpsewhich --expand-path='$$TEXMFDEBIAN')
%:
dh $@ --without cmake --buildsystem qmake
+override_dh_auto_install:
+ install -D -m 644 tex/sample/tikzit.sty debian/tikzit/$(TEXMFDEBIAN)/tex/latex/tikzit/tikzit.sty
+ dh_auto_install
+
# The tests require X.
override_dh_auto_test: