summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-04-08 11:24:02 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-04-08 11:24:02 +0000
commita242702ce22f379e11708cbf32a7e7433c4c5d01 (patch)
treebf5dd9418dbc877ad40414d724fb1027d0906f9f /CMakeLists.txt
parenteaae83fc6b471bb05891addd35863fe00c351565 (diff)
parentcb457ffb26e05ed619eb55676ae6d569f7497284 (diff)
backmerge of last trunk modification
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/bottleneckDistance@552 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 1c2b73b7bee36af96a3a9c445a7722e2921f43d7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 7 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89440490..f30c1785 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,28 +32,16 @@ endif()
find_package(CGAL)
# Required programs for unitary tests purpose
-FIND_PROGRAM( LCOV_PATH lcov )
-if (LCOV_PATH)
- message("lcov found in ${LCOV_PATH}")
+FIND_PROGRAM( GCOVR_PATH gcovr )
+if (GCOVR_PATH)
+ message("gcovr found in ${GCOVR_PATH}")
endif()
-
-FIND_PROGRAM( PYTHON_PATH python )
-if (PYTHON_PATH)
- message("python found in ${PYTHON_PATH}")
+# Required programs for unitary tests purpose
+FIND_PROGRAM( GPROF_PATH gprof )
+if (GPROF_PATH)
+ message("gprof found in ${GPROF_PATH}")
endif()
-# Function to add_test cpplint on each header file of the Gudhi module
-function(cpplint_add_tests the_directory)
- if (PYTHON_PATH)
- # Cpplint tests on coding style
- file(GLOB files "${the_directory}/*.h" "${the_directory}/*/*.h")
- foreach(filename ${files})
- message(${filename})
- add_test("${filename}.cpplint" ${CMAKE_SOURCE_DIR}/scripts/check_google_style.sh ${filename} ${CMAKE_SOURCE_DIR}/scripts/cpplint.py)
- endforeach()
- endif()
-endfunction(cpplint_add_tests)
-
if(NOT Boost_FOUND)
message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")