summaryrefslogtreecommitdiff
path: root/src/Bottleneck_distance/benchmark/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-03-24 23:33:35 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-03-24 23:33:35 +0000
commit6ed42daddfede2288bc02ab2e98fc12b47cac74e (patch)
tree4f755cd70e7745164f31f1f5f0941dc8284c331d /src/Bottleneck_distance/benchmark/CMakeLists.txt
parent472bfd399cd1c29a03d20cc5cffe56dfb263717c (diff)
parent70960dc646b6cfa396584ab4997aeef76424154d (diff)
Merge cgal_4.8_issue branch into the trunk
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@2242 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 094b70b4141e7456651263b1619240aff6a5d562
Diffstat (limited to 'src/Bottleneck_distance/benchmark/CMakeLists.txt')
-rw-r--r--src/Bottleneck_distance/benchmark/CMakeLists.txt17
1 files changed, 6 insertions, 11 deletions
diff --git a/src/Bottleneck_distance/benchmark/CMakeLists.txt b/src/Bottleneck_distance/benchmark/CMakeLists.txt
index c99e0373..170081ce 100644
--- a/src/Bottleneck_distance/benchmark/CMakeLists.txt
+++ b/src/Bottleneck_distance/benchmark/CMakeLists.txt
@@ -1,14 +1,9 @@
cmake_minimum_required(VERSION 2.6)
project(Bottleneck_distance_benchmark)
-
-# requires CGAL 4.8
-# cmake -DCGAL_DIR=~/workspace/CGAL-4.8 ../../..
-if(CGAL_FOUND)
- if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
- add_executable ( bottleneck_chrono bottleneck_chrono.cpp )
- if (TBB_FOUND)
- target_link_libraries(bottleneck_chrono ${TBB_LIBRARIES})
- endif(TBB_FOUND)
- endif ()
-endif()
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+ add_executable ( bottleneck_chrono bottleneck_chrono.cpp )
+ if (TBB_FOUND)
+ target_link_libraries(bottleneck_chrono ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)