summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-04-08 15:46:05 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-04-08 15:46:05 +0000
commit03b700251ba8aee55e1cca1038d397135f1c9408 (patch)
tree0bc2806d6769e981e2610696517667b3fcbc5fbb /src/CMakeLists.txt
parent178b86f53cb16964de4365948ada341b7012c1da (diff)
parent607fc8aa10122089aa2b3debf36e48250e2dfb5b (diff)
Merge of alpha complex feature from trunk
Add Eigen3 in installation Add alpha complex in introduction All examples directory moved to example (was example/common, example/Alpha_complex) git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/Doxygen_for_GUDHI_1.3.0@1110 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 0b88a4f2b102e2189f4b916b8358ffb2458a72f0
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt21
1 files changed, 16 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 60315338..1700ddaa 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -2,6 +2,8 @@ cmake_minimum_required(VERSION 2.6)
project(GUDHI)
include("CMakeGUDHIVersion.txt")
+# Generate GUDHI official version file
+configure_file(GUDHIVersion.cmake.in "${CMAKE_SOURCE_DIR}/GUDHIVersion.cmake" @ONLY)
enable_testing()
@@ -71,16 +73,24 @@ else()
INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
+ if (DEBUG_TRACES)
+ message(STATUS "DEBUG_TRACES are activated")
+ # For programs to be more verbose
+ add_definitions(-DDEBUG_TRACES)
+ endif()
+
#---------------------------------------------------------------------------------------
# Gudhi compilation part
include_directories(include)
- #add_subdirectory(example/Simplex_tree)
- #add_subdirectory(example/Persistent_cohomology)
- #add_subdirectory(example/Skeleton_blocker)
- #add_subdirectory(example/Contraction)
+ add_subdirectory(example/common)
+ add_subdirectory(example/Simplex_tree)
+ add_subdirectory(example/Persistent_cohomology)
+ add_subdirectory(example/Skeleton_blocker)
+ add_subdirectory(example/Contraction)
add_subdirectory(example/Bitmap_cubical_complex)
add_subdirectory(example/Witness_complex)
+ add_subdirectory(example/Alpha_complex)
# data points generator
add_subdirectory(data/points/generator)
@@ -96,8 +106,9 @@ else()
# (this registers the build-tree with a global CMake-registry)
export(PACKAGE GUDHI)
+ message("++ make install will install ${PROJECT_NAME} in the following directory : ${CMAKE_INSTALL_PREFIX}")
# Create the GUDHIConfig.cmake and GUDHIConfigVersion files
- set(CONF_INCLUDE_DIRS "${PROJECT_SOURCE_DIR}/include")
+ set(CONF_INCLUDE_DIRS "${CMAKE_INSTALL_PREFIX}/include")
configure_file(GUDHIConfig.cmake.in "${PROJECT_BINARY_DIR}/GUDHIConfig.cmake" @ONLY)
configure_file(GUDHIConfigVersion.cmake.in "${PROJECT_BINARY_DIR}/GUDHIConfigVersion.cmake" @ONLY)