summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-11-04 08:26:01 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-11-04 08:26:01 +0100
commitdaa3b08931e830212bc09130f7040d98d257b08f (patch)
treea4ad2e1f2a186a78aae05d8ca37c2da2bce1b75e /src/CMakeLists.txt
parenta07430764c57c195c9260fc1b301ba0aeb77dcc7 (diff)
parent56dc7eb47cce596ee345dd7c6605dbee2f412f5e (diff)
Merge branch 'master' into weighted_alpha_complex_dD
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cc230531..79ec42c1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -50,6 +50,14 @@ include_directories(include)
# Include module CMake subdirectories
# GUDHI_SUB_DIRECTORIES is managed in CMAKE_MODULE_PATH/GUDHI_modules.cmake
+if (WITH_GUDHI_PYTHON)
+ # specific for cython module
+ add_subdirectory(${GUDHI_PYTHON_PATH})
+else()
+ message("++ Python module will not be compiled because WITH_GUDHI_PYTHON is set to OFF")
+ set(GUDHI_MISSING_MODULES ${GUDHI_MISSING_MODULES} "python")
+endif()
+
foreach(GUDHI_MODULE ${GUDHI_MODULES})
foreach(GUDHI_SUB_DIRECTORY ${GUDHI_SUB_DIRECTORIES})
if(EXISTS ${CMAKE_SOURCE_DIR}/${GUDHI_SUB_DIRECTORY}/${GUDHI_MODULE}/CMakeLists.txt)
@@ -60,14 +68,6 @@ endforeach()
add_subdirectory(GudhUI)
-if (WITH_GUDHI_PYTHON)
- # specific for cython module
- add_subdirectory(${GUDHI_PYTHON_PATH})
-else()
- message("++ Python module will not be compiled because WITH_GUDHI_PYTHON is set to OFF")
- set(GUDHI_MISSING_MODULES ${GUDHI_MISSING_MODULES} "python")
-endif()
-
message("++ GUDHI_MODULES list is:\"${GUDHI_MODULES}\"")
message("++ GUDHI_MISSING_MODULES list is:\"${GUDHI_MISSING_MODULES}\"")