summaryrefslogtreecommitdiff
path: root/src/Cech_complex/benchmark/CMakeLists.txt
diff options
context:
space:
mode:
authormcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-08-28 21:20:08 +0000
committermcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-08-28 21:20:08 +0000
commit421d41de2ba46670d04f4b0269c034a6be9f42bd (patch)
treea6149e5a7a9e6504800493c06e793a8fc660f3c6 /src/Cech_complex/benchmark/CMakeLists.txt
parentd34354883a5021ab9beaa03f7739378caf3e5683 (diff)
parent0784baddd1392727289a972b8374b3c2dca940a9 (diff)
added function to read point cloud from array in memory + changed a little bit the API
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/Nerve_GIC@3841 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: f31a3a60b2438d7b767a1ee310d859477330a743
Diffstat (limited to 'src/Cech_complex/benchmark/CMakeLists.txt')
-rw-r--r--src/Cech_complex/benchmark/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/Cech_complex/benchmark/CMakeLists.txt b/src/Cech_complex/benchmark/CMakeLists.txt
new file mode 100644
index 00000000..b7697764
--- /dev/null
+++ b/src/Cech_complex/benchmark/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 2.6)
+project(Cech_complex_benchmark)
+
+# Do not forget to copy test files in current binary dir
+file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+add_executable(cech_complex_benchmark cech_complex_benchmark.cpp)
+target_link_libraries(cech_complex_benchmark ${Boost_SYSTEM_LIBRARY} ${Boost_FILESYSTEM_LIBRARY})
+
+if (TBB_FOUND)
+ target_link_libraries(cech_complex_benchmark ${TBB_LIBRARIES})
+endif()