summaryrefslogtreecommitdiff
path: root/src/Collapse/example/CMakeLists.txt
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-03-16 23:06:09 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-03-16 23:06:09 +0100
commitca63b38beafa9f5bb0b674682764e26097380134 (patch)
tree4092f672efd755214e56fb815e1ef1b7fd5ab92a /src/Collapse/example/CMakeLists.txt
parentf40161072b8f74f68b0ff67b6ef2be7abebec950 (diff)
Collapse first version from Siddharth
Diffstat (limited to 'src/Collapse/example/CMakeLists.txt')
-rw-r--r--src/Collapse/example/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Collapse/example/CMakeLists.txt b/src/Collapse/example/CMakeLists.txt
new file mode 100644
index 00000000..c9cba3fa
--- /dev/null
+++ b/src/Collapse/example/CMakeLists.txt
@@ -0,0 +1,9 @@
+project(Collapse_examples)
+
+add_executable ( Collapse_example_rips_persistence_with_collapse rips_persistence_with_sc.cpp )
+target_link_libraries(Collapse_example_rips_persistence_with_collapse Boost::program_options)
+
+if (TBB_FOUND)
+ target_link_libraries(Collapse_example_rips_persistence_with_collapse ${TBB_LIBRARIES})
+endif()
+add_test(NAME Collapse_example_rips_persistence_with_collapse COMMAND $<TARGET_FILE:Collapse_example_rips_persistence_with_collapse>)