summaryrefslogtreecommitdiff
path: root/src/Persistent_cohomology/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-02-06 14:25:38 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-02-06 14:25:38 +0000
commit8802dc5353020c75012f6ae8c26afefb4c78b161 (patch)
treec264b84d49f442205afb34d88c8cfaab0e54361f /src/Persistent_cohomology/example/CMakeLists.txt
parent2d4979f6e6b9e502b1c5051d5a35935c4a65ac8c (diff)
Add of persistence computation from a simple simplex tree - Fix of infinite persistent (1.#INF under windows) UT
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@462 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: f08233c68f60962fa6caa5603b3a8b4a16b2bb76
Diffstat (limited to 'src/Persistent_cohomology/example/CMakeLists.txt')
-rw-r--r--src/Persistent_cohomology/example/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
index 842f852a..3697a419 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
@@ -3,6 +3,9 @@ project(GUDHIExPersCohom)
# problem with Visual Studio link on Boost program_options
if (NOT MSVC)
+ add_executable(persistence_from_simple_simplex_tree persistence_from_simple_simplex_tree.cpp)
+ target_link_libraries(persistence_from_simple_simplex_tree ${Boost_SYSTEM_LIBRARY})
+
add_executable(rips_persistence rips_persistence.cpp)
target_link_libraries(rips_persistence ${Boost_SYSTEM_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY})