summaryrefslogtreecommitdiff
path: root/src/Persistent_cohomology/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-10-02 20:12:44 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-10-02 20:12:44 +0000
commit8a3c2975bab46014e9c89837ee5d39cb68473350 (patch)
treebbc295cc3a4f88418d3048a177d5df6528b59ee1 /src/Persistent_cohomology/example/CMakeLists.txt
parent9ed5279c478f5d79151e7f99390da7eb23f11550 (diff)
Fix weighted periodic
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/weighted_alpha_complex_fix@2746 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: bf90bfffbc00efe5f391e45ac8ece6ff6e9d57ea
Diffstat (limited to 'src/Persistent_cohomology/example/CMakeLists.txt')
-rw-r--r--src/Persistent_cohomology/example/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
index f6c866dc..5f711961 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
@@ -123,6 +123,13 @@ if(CGAL_FOUND)
install(TARGETS weighted_periodic_alpha_complex_3d_persistence DESTINATION bin)
+ add_executable(test_cgal test_cgal.cpp)
+ target_link_libraries(test_cgal ${CGAL_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(test_cgal ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+
+
# On CGAL 4.11, the weighted alpha shape 3 interface was changed - the new interface
add_executable(weighted_alpha_complex_3d_persistence weighted_alpha_complex_3d_persistence.cpp)
else(NOT CGAL_VERSION VERSION_LESS 4.11.0)