summaryrefslogtreecommitdiff
path: root/src/Persistent_cohomology/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-10-10 12:52:35 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-10-10 12:52:35 +0000
commitfb7c3e76da15aca382ed7a6795d1a6fb3c1716c2 (patch)
tree6b7958a391c189192b26424246a9039c300e2053 /src/Persistent_cohomology/example/CMakeLists.txt
parentf1e2834261bae80eb216bcd9317538e5de4375a9 (diff)
Fix CGAL 4.11 bug and remove old_interface file. Better done with #if
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/weighted_alpha_complex_fix@2774 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 9a905b04cfa2718f9d5abc80e14ab1ee26d16279
Diffstat (limited to 'src/Persistent_cohomology/example/CMakeLists.txt')
-rw-r--r--src/Persistent_cohomology/example/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
index be23de35..e82ef04c 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
@@ -127,15 +127,9 @@ if(CGAL_FOUND)
install(TARGETS weighted_periodic_alpha_complex_3d_persistence DESTINATION bin)
- # On CGAL 4.11, the weighted alpha shape 3 interface was changed - the new interface
- add_executable(weighted_alpha_complex_3d_persistence weighted_alpha_complex_3d_persistence.cpp)
- else(NOT CGAL_VERSION VERSION_LESS 4.11.0)
- # On CGAL 4.11, the weighted alpha shape 3 interface was changed - the old interface
- add_executable(weighted_alpha_complex_3d_persistence weighted_alpha_complex_3d_persistence_old_cgal_interface.cpp)
endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
- # cf. if (NOT CGAL_VERSION VERSION_LESS 4.11.0) and else(NOT CGAL_VERSION VERSION_LESS 4.11.0)
- # same target name on purpose
+ add_executable(weighted_alpha_complex_3d_persistence weighted_alpha_complex_3d_persistence.cpp)
target_link_libraries(weighted_alpha_complex_3d_persistence ${CGAL_LIBRARY})
if (TBB_FOUND)
target_link_libraries(weighted_alpha_complex_3d_persistence ${TBB_LIBRARIES})