summaryrefslogtreecommitdiff
path: root/src/Persistent_cohomology/example/CMakeLists.txt
diff options
context:
space:
mode:
authorsalinasd <salinasd@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-18 15:10:47 +0000
committersalinasd <salinasd@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-18 15:10:47 +0000
commit1f7bb62cc29e767590f16e1b8cc9faca2bfed670 (patch)
treeb54d69db873e5866c3713b564219c5e85d5c7379 /src/Persistent_cohomology/example/CMakeLists.txt
parenta255b6f2af1c24d7b84ef2c71cd85799415b1ac8 (diff)
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@387 636b058d-ea47-450e-bf9e-a15bfbe3eedb
Former-commit-id: f1da07dec37086bcf40a92ea05a245dac0e62f8b
Diffstat (limited to 'src/Persistent_cohomology/example/CMakeLists.txt')
-rw-r--r--src/Persistent_cohomology/example/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
index 1bb7fe09..08ebc294 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
@@ -4,13 +4,13 @@ project(GUDHIExPersCohom)
add_executable(rips_persistence rips_persistence.cpp)
-target_link_libraries(rips_persistence ${Boost_PROGRAM_OPTIONS_LIBRARY} ${Boost_SYSTEM_LIBRARY})
+target_link_libraries(rips_persistence ${Boost_LIBRARY_DIR})
add_test(rips_persistence_2 ${CMAKE_CURRENT_BINARY_DIR}/rips_persistence ${CMAKE_SOURCE_DIR}/data/points/Kl.txt -r 0.25 -d 3 -p 2 -m 100)
add_test(rips_persistence_3 ${CMAKE_CURRENT_BINARY_DIR}/rips_persistence ${CMAKE_SOURCE_DIR}/data/points/Kl.txt -r 0.25 -d 3 -p 3 -m 100)
add_executable(persistence_from_file persistence_from_file.cpp)
-target_link_libraries(persistence_from_file ${Boost_PROGRAM_OPTIONS_LIBRARY} ${Boost_SYSTEM_LIBRARY})
+target_link_libraries(persistence_from_file ${Boost_LIBRARY_DIR})
add_test(persistence_from_file_3_2_0 ${CMAKE_CURRENT_BINARY_DIR}/persistence_from_file ${CMAKE_SOURCE_DIR}/data/points/bunny_5000.st -p 2 -m 0)
add_test(persistence_from_file_3_3_100 ${CMAKE_CURRENT_BINARY_DIR}/persistence_from_file ${CMAKE_SOURCE_DIR}/data/points/bunny_5000.st -p 3 -m 100)
@@ -19,10 +19,10 @@ if(GMPXX_FOUND AND GMP_FOUND)
message("GMP_LIBRARIES = ${GMP_LIBRARIES}")
add_executable(rips_multifield_persistence rips_multifield_persistence.cpp )
- target_link_libraries(rips_multifield_persistence ${Boost_PROGRAM_OPTIONS_LIBRARY} ${Boost_SYSTEM_LIBRARY} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES})
+ target_link_libraries(rips_multifield_persistence ${Boost_LIBRARY_DIR} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES})
add_test(rips_multifield_persistence_2_3 ${CMAKE_CURRENT_BINARY_DIR}/rips_multifield_persistence ${CMAKE_SOURCE_DIR}/data/points/Kl.txt -r 0.25 -d 3 -p 2 -q 3 -m 100)
add_test(rips_multifield_persistence_2_71 ${CMAKE_CURRENT_BINARY_DIR}/rips_multifield_persistence ${CMAKE_SOURCE_DIR}/data/points/Kl.txt -r 0.25 -d 3 -p 2 -q 71 -m 100)
add_executable ( performance_rips_persistence performance_rips_persistence.cpp )
- target_link_libraries(performance_rips_persistence ${Boost_PROGRAM_OPTIONS_LIBRARY} ${Boost_SYSTEM_LIBRARY} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES})
+ target_link_libraries(performance_rips_persistence ${Boost_LIBRARY_DIR} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES})
endif()