summaryrefslogtreecommitdiff
path: root/src/Subsampling/example/CMakeLists.txt
diff options
context:
space:
mode:
authorskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-28 17:34:51 +0000
committerskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-09-28 17:34:51 +0000
commite10dbc80a604cd1f53a4e9fee432d71c543a70a4 (patch)
tree167db5ca63c723fee6e7269b3478b63c7029f400 /src/Subsampling/example/CMakeLists.txt
parent706d447efdb0da311f02b3677ce19e4a68100b03 (diff)
parent853bd71a57e36773a422698992527570587ec999 (diff)
Rewrite for the Weak Witness Complex
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/relaxed-witness@1586 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 00d6d906598893ab551157c00020ce33fe19cb5b
Diffstat (limited to 'src/Subsampling/example/CMakeLists.txt')
-rw-r--r--src/Subsampling/example/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/Subsampling/example/CMakeLists.txt b/src/Subsampling/example/CMakeLists.txt
new file mode 100644
index 00000000..81b39d6e
--- /dev/null
+++ b/src/Subsampling/example/CMakeLists.txt
@@ -0,0 +1,22 @@
+cmake_minimum_required(VERSION 2.6)
+project(Subsampling_examples)
+
+if(CGAL_FOUND)
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+ message(STATUS "CGAL version: ${CGAL_VERSION}.")
+
+ if (EIGEN3_FOUND)
+
+ add_executable(Subsampling_example_pick_n_random_points example_pick_n_random_points.cpp)
+ add_executable(Subsampling_example_choose_n_farthest_points example_choose_n_farthest_points.cpp)
+ add_executable(Subsampling_example_sparsify_point_set example_sparsify_point_set.cpp)
+ target_link_libraries(Subsampling_example_sparsify_point_set ${CGAL_LIBRARY})
+ else()
+ message(WARNING "Eigen3 not found. Version 3.1.0 is required for Subsampling feature.")
+ endif()
+ else()
+ message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile Subsampling examples. Version 4.8.1 is required.")
+ endif ()
+else()
+ message(WARNING "CGAL not found. It is required for the Subsampling examples.")
+endif()