summaryrefslogtreecommitdiff
path: root/src/Subsampling/test/CMakeLists.txt
diff options
context:
space:
mode:
authorskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-21 09:20:44 +0000
committerskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-21 09:20:44 +0000
commit1539aa803375bbb562559ab632d8ce22c6ce940b (patch)
treef92498789d5ff9de93f8d5402987b710eb3edbf1 /src/Subsampling/test/CMakeLists.txt
parent80c45e3f6a8a1f823840b3ae9e924362d7e376b7 (diff)
Merged the CMakeLists and added test_choose_by_farthest_point
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1318 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 534a2ac30a2177a780d1f483add2c472d4cedac3
Diffstat (limited to 'src/Subsampling/test/CMakeLists.txt')
-rw-r--r--src/Subsampling/test/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/Subsampling/test/CMakeLists.txt b/src/Subsampling/test/CMakeLists.txt
index 1785b86d..3a7fc092 100644
--- a/src/Subsampling/test/CMakeLists.txt
+++ b/src/Subsampling/test/CMakeLists.txt
@@ -1,6 +1,16 @@
cmake_minimum_required(VERSION 2.6)
project(Subsampling_tests)
+if (GCOVR_PATH)
+ # for gcovr to make coverage reports - Corbera Jenkins plugin
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fprofile-arcs -ftest-coverage")
+endif()
+if (GPROF_PATH)
+ # for gprof to make coverage reports - Jenkins
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pg")
+endif()
+
+# Landmarking test
if(CGAL_FOUND)
if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
message(STATUS "CGAL version: ${CGAL_VERSION}.")
@@ -11,7 +21,9 @@ if(CGAL_FOUND)
include( ${EIGEN3_USE_FILE} )
include_directories (BEFORE "../../include")
- add_executable( landmarking_UT landmarking.cpp )
+ add_executable( test_choose_farthest_point test_choose_farthest_point.cpp )
+ target_link_libraries(test_choose_farthest_point ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+
add_executable( Subsampling_test_sparsify_point_set test_sparsify_point_set.cpp)
else()
message(WARNING "Eigen3 not found. Version 3.1.0 is required for Subsampling feature.")