summaryrefslogtreecommitdiff
path: root/src/Tangential_complex/benchmark/CMakeLists.txt
diff options
context:
space:
mode:
authorskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-11-18 16:26:37 +0000
committerskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-11-18 16:26:37 +0000
commit786f13354f48a652232ca51112386ed0173f23d1 (patch)
treeae320abe21a40f7459c1ac9bac6da0f36525eb9c /src/Tangential_complex/benchmark/CMakeLists.txt
parentf891467fe38d7757aa3d92705ca99e847cdd68d9 (diff)
parent49ba4f283d9a742b4dbc7ef966f2cb769a87c4d1 (diff)
Merged trunc in witness
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/relaxed-witness@1761 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 67fd48a872fb297cd04ba127bb0778c5216f0a41
Diffstat (limited to 'src/Tangential_complex/benchmark/CMakeLists.txt')
-rw-r--r--src/Tangential_complex/benchmark/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/Tangential_complex/benchmark/CMakeLists.txt b/src/Tangential_complex/benchmark/CMakeLists.txt
new file mode 100644
index 00000000..a217d6e6
--- /dev/null
+++ b/src/Tangential_complex/benchmark/CMakeLists.txt
@@ -0,0 +1,26 @@
+cmake_minimum_required(VERSION 2.6)
+project(Tangential_complex_benchmark)
+
+if (GCOVR_PATH)
+ # for gcovr to make coverage reports - Corbera Jenkins plugin
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fprofile-arcs -ftest-coverage")
+endif()
+if (GPROF_PATH)
+ # for gprof to make coverage reports - Jenkins
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pg")
+endif()
+
+# need CGAL 4.8
+if(CGAL_FOUND)
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ if (EIGEN3_FOUND)
+ add_executable(Tangential_complex_benchmark benchmark_tc.cpp)
+ target_link_libraries(Tangential_complex_benchmark
+ ${Boost_DATE_TIME_LIBRARY} ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Tangential_complex_benchmark ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+ endif(EIGEN3_FOUND)
+ endif (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+endif(CGAL_FOUND)
+