summaryrefslogtreecommitdiff
path: root/src/Witness_complex/example/CMakeLists.txt
diff options
context:
space:
mode:
authorskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-12-07 09:39:53 +0000
committerskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-12-07 09:39:53 +0000
commit33c51358238382335caf892bbc24759c8aac59a0 (patch)
tree499e768570391c30af22eac4443667604fa717d6 /src/Witness_complex/example/CMakeLists.txt
parentda39f7cd8a0db5d7fa13c9c87f8fc3e038c10d01 (diff)
parentc8c2f91db880218bb7ab275fbadda53a23f88d35 (diff)
Changes piled up for months
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/witness@932 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 0447901e608890eb607456fd12f3ea53547b8f10
Diffstat (limited to 'src/Witness_complex/example/CMakeLists.txt')
-rw-r--r--src/Witness_complex/example/CMakeLists.txt14
1 files changed, 3 insertions, 11 deletions
diff --git a/src/Witness_complex/example/CMakeLists.txt b/src/Witness_complex/example/CMakeLists.txt
index 23919b4a..ff372d16 100644
--- a/src/Witness_complex/example/CMakeLists.txt
+++ b/src/Witness_complex/example/CMakeLists.txt
@@ -1,16 +1,7 @@
cmake_minimum_required(VERSION 2.6)
project(GUDHIWitnessComplex)
-#cmake -DCGAL_DIR=~/GitDrive/CGAL/ ../../..
-#if (CGAL_FOUND)
- #message(STATUS "CGAL version: ${CGAL_VERSION}.")
- #include( ${CGAL_USE_FILE} )
-
- #find_package(Eigen3 3.1.0)
- #include( ${EIGEN3_USE_FILE} )
-
- #INCLUDE_DIRECTORIES(${EIGEN3_INCLUDE_DIR})
- #INCLUDE_DIRECTORIES(${CGAL_INCLUDE_DIRS})
+# A simple example
add_executable ( simple_witness_complex simple_witness_complex.cpp )
add_test(simple_witness_complex ${CMAKE_CURRENT_BINARY_DIR}/simple_witness_complex)
@@ -21,7 +12,7 @@ project(GUDHIWitnessComplex)
add_executable( witness_complex_from_off witness_complex_from_off.cpp )
add_executable( witness_complex_from_wl_matrix witness_complex_from_wl_matrix.cpp )
-#endif()
+
# An example with Simplex-tree using CGAL alpha_shapes_3
@@ -51,6 +42,7 @@ if(CGAL_FOUND)
if (EIGEN3_FOUND)
message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
include( ${EIGEN3_USE_FILE} )
+ message(STATUS "Eigen3 use file: ${EIGEN3_USE_FILE}.")
include_directories (BEFORE "../../include")
add_executable ( witness_complex_knn_landmarks witness_complex_knn_landmarks.cpp )