summaryrefslogtreecommitdiff
path: root/src/common/utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-06-20 13:13:22 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-06-20 13:13:22 +0000
commit1f77137e23ddb39b6c3bdd9ea26b99e2feecfd60 (patch)
tree0b4934d5e78b6daadf65dee52dd97af2243eaa5d /src/common/utilities/CMakeLists.txt
parent2efd0154ec5299a175ea2633db0dd739a620762d (diff)
parentf3c41e18d5122dffd98c49412c364f0a07ee0bb6 (diff)
Merge last trunk modifications
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/Spatial_searching-Add_radius_search@2555 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 3d0a3b2988bbbd0baa19fc09ba77e4e58e330a89
Diffstat (limited to 'src/common/utilities/CMakeLists.txt')
-rw-r--r--src/common/utilities/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/common/utilities/CMakeLists.txt b/src/common/utilities/CMakeLists.txt
new file mode 100644
index 00000000..c2e07e7e
--- /dev/null
+++ b/src/common/utilities/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 2.6)
+project(off_file_from_shape_generator)
+
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.6.0)
+ add_executable ( off_file_from_shape_generator off_file_from_shape_generator.cpp )
+ target_link_libraries(off_file_from_shape_generator ${Boost_SYSTEM_LIBRARY})
+ add_test(NAME off_file_from_shape_generator_on_sphere_1000_3_15.2 COMMAND $<TARGET_FILE:off_file_from_shape_generator>
+ "on" "sphere" "onSphere.off" "1000" "3" "15.2")
+ add_test(NAME off_file_from_shape_generator_in_sphere_100_2 COMMAND $<TARGET_FILE:off_file_from_shape_generator>
+ "in" "sphere" "inSphere.off" "100" "2")
+
+ # on cube is not available in CGAL
+ add_test(NAME off_file_from_shape_generator_in_cube_10000_3_5.8 COMMAND $<TARGET_FILE:off_file_from_shape_generator>
+ "in" "cube" "inCube.off" "10000" "3" "5.8")
+
+ install(TARGETS off_file_from_shape_generator DESTINATION bin)
+
+endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.6.0)