summaryrefslogtreecommitdiff
path: root/src/cython/setup.py
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-05-13 16:26:46 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-05-13 16:26:46 +0000
commit1260fc74aeb7c4f82af913388dda0cf0d54dba07 (patch)
treead4e7b1bedeedfb1d56a04e3423f2883b99f2dcc /src/cython/setup.py
parent5056cf3b1626a04879f637d5bce9af61080e8950 (diff)
Alpha complex without get_point (still bugging)
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/ST_cythonize@1175 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: f6e9487d9b129adebda64089ba5590b2f9b9f5e7
Diffstat (limited to 'src/cython/setup.py')
-rw-r--r--src/cython/setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/cython/setup.py b/src/cython/setup.py
index 8439a071..92ed6bbd 100644
--- a/src/cython/setup.py
+++ b/src/cython/setup.py
@@ -5,8 +5,10 @@ gudhi = Extension(
"gudhi",
sources = ['gudhi.pyx',],
language = 'c++',
- extra_compile_args=['-std=c++11'],
- include_dirs = ['../include','./src/cpp'],
+ extra_compile_args=['-frounding-math','-std=c++11','-DCGAL_EIGEN3_ENABLED','-DCGAL_USE_GMP','-DCGAL_USE_GMPXX','-DCGAL_USE_MPFR'],
+ libraries=['mpfr','gmpxx','gmp','CGAL'],
+ library_dirs=['/usr/local/lib/'],
+ include_dirs = ['../include','./src/cpp','/usr/local/include/eigen3'],
)
setup(