summaryrefslogtreecommitdiff
path: root/src/debian/rules
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-04-15 11:40:04 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-04-15 11:40:04 +0000
commit361f34afa127d69e447008b75a198a286b99ea08 (patch)
tree5bf1d290745d14ec31336042e1a3f190813b4659 /src/debian/rules
parentc0bff602db910fbda4449299e48df469c0457fb9 (diff)
parenta44155daa5ae4253a874dad4a22b6da4bd017fee (diff)
Add of debian package constructor
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@1120 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 21a3e45155cf66e8e585d4fd61f2f29ca18e67cd
Diffstat (limited to 'src/debian/rules')
-rwxr-xr-xsrc/debian/rules28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/debian/rules b/src/debian/rules
new file mode 100755
index 00000000..c9b049af
--- /dev/null
+++ b/src/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+
+# main packaging script based on dh7 syntax
+%:
+ dh $@
+
+# dh_make generated override targets
+# This is example for Cmake (See https://bugs.debian.org/641051 )
+#override_dh_auto_configure:
+# dh_auto_configure -- \
+# -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)