summaryrefslogtreecommitdiff
path: root/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2020-06-12 01:33:21 -0700
committerGitHub <noreply@github.com>2020-06-12 01:33:21 -0700
commit4eaf784a5f7d48466f0d602225629d693a713d14 (patch)
tree4300b65a5abe38eb2c488044a459a40864bdd37f /src/python/CMakeLists.txt
parent58f7cd2d1fec9b12665ad10c16b9812eba303570 (diff)
parent4ae747be301f1f159f36bd9d3c103774e1ad80ac (diff)
Merge pull request #335 from VincentRouvreau/gudhi_pip_package
gudhi pip package for version 3.2.0
Diffstat (limited to 'src/python/CMakeLists.txt')
-rw-r--r--src/python/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 1e81cac8..81be1b76 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -239,6 +239,9 @@ if(PYTHONINTERP_FOUND)
file(COPY "gudhi/dtm_rips_complex.py" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/gudhi")
file(COPY "gudhi/hera/__init__.py" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/gudhi/hera")
+ # Some files for pip package
+ file(COPY "introduction.rst" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/")
+
add_custom_command(
OUTPUT gudhi.so
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}