summaryrefslogtreecommitdiff
path: root/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authoryuichi-ike <yuichi.ike.1990@gmail.com>2020-05-12 09:37:32 +0900
committeryuichi-ike <yuichi.ike.1990@gmail.com>2020-05-12 09:37:32 +0900
commit6c17494e02721ca826750155bac14c7f91a173fa (patch)
tree94caf6a3852dd82f8c1b13f4394ee02e3e52661f /src/python/CMakeLists.txt
parent5040c75893cb864f5e780b6644b8097f7beeb3a6 (diff)
reference and comments added
Diffstat (limited to 'src/python/CMakeLists.txt')
-rw-r--r--src/python/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index adf4923b..0aa55467 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -487,7 +487,9 @@ if(PYTHONINTERP_FOUND)
endif()
# Weighted Rips
- add_gudhi_py_test(test_weighted_rips)
+ if(SCIPY_FOUND)
+ add_gudhi_py_test(test_weighted_rips)
+ endif()
# Set missing or not modules
set(GUDHI_MODULES ${GUDHI_MODULES} "python" CACHE INTERNAL "GUDHI_MODULES")