summaryrefslogtreecommitdiff
path: root/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-06-25 08:54:00 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-06-25 08:54:00 +0200
commit8116cae8a3cdd5d9c02725086733ae5a33f39634 (patch)
treeae7238987c80b324903f9d48d7a7377e06c445ce /src/python/CMakeLists.txt
parent078db27a01c696bba81737f3b722255af7fa2619 (diff)
Error messages
Diffstat (limited to 'src/python/CMakeLists.txt')
-rw-r--r--src/python/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index c9f30bcf..0182e4f5 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -16,9 +16,11 @@ endfunction( add_GUDHI_PYTHON_lib )
function( add_GUDHI_PYTHON_lib_dir THE_LIB_DIR )
# deals when it is not set - error on windows
- if(EXISTS ${LIB_DIR})
- set(GUDHI_PYTHON_LIBRARY_DIRS "${GUDHI_PYTHON_LIBRARY_DIRS}'${LIB_DIR}', ")
- endif(EXISTS ${LIB_DIR})
+ if(EXISTS ${THE_LIB_DIR})
+ set(GUDHI_PYTHON_LIBRARY_DIRS "${GUDHI_PYTHON_LIBRARY_DIRS}'${THE_LIB_DIR}', ")
+ else()
+ message("add_GUDHI_PYTHON_lib_dir - '${THE_LIB_DIR}' does not exist")
+ endif()
endfunction( add_GUDHI_PYTHON_lib_dir )
# THE_TEST is the python test file name (without .py extension) containing tests functions
@@ -201,7 +203,7 @@ if(PYTHONINTERP_FOUND)
message("MPFR_LIBRARIES_DIR from MPFR_LIBRARIES set to ${MPFR_LIBRARIES_DIR}")
endif(NOT MPFR_LIBRARIES_DIR)
add_GUDHI_PYTHON_lib_dir("${MPFR_LIBRARIES_DIR}")
- message("** Add mpfr ${MPFR_LIBRARIES_DIR} - release ${MPFR_LIBRARIES_DIR_RELEASE} - debug ${MPFR_LIBRARIES_DIR_DEBUG}")
+ message("** Add mpfr ${MPFR_LIBRARIES_DIR}")
endif(MPFR_FOUND)
endif(CGAL_FOUND)