summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ff9f14c1..c5d139fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,10 +21,11 @@ endif()
# BOOST ISSUE result_of vs C++11
add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
-
find_package(Boost)
find_package(GMP)
-find_package(GMPXX)
+if(GMP_FOUND)
+ find_package(GMPXX)
+endif()
find_package(CGAL)
# Required programs for unitary tests purpose
@@ -69,7 +70,6 @@ else()
add_subdirectory(src/Persistent_cohomology/example)
add_subdirectory(src/Skeleton_blocker/test)
add_subdirectory(src/Skeleton_blocker/example)
- add_subdirectory(src/Contraction/test)
add_subdirectory(src/Contraction/example)
endif()