summaryrefslogtreecommitdiff
path: root/src/Gudhi_stat/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Gudhi_stat/test/CMakeLists.txt')
-rw-r--r--src/Gudhi_stat/test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Gudhi_stat/test/CMakeLists.txt b/src/Gudhi_stat/test/CMakeLists.txt
index 292549f8..4ae09663 100644
--- a/src/Gudhi_stat/test/CMakeLists.txt
+++ b/src/Gudhi_stat/test/CMakeLists.txt
@@ -16,10 +16,13 @@ endif()
# copy data directory for tests purpose
file(COPY data DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+# Do not forget to copy test files in current binary dir
+file(COPY "${CMAKE_SOURCE_DIR}/src/Gudhi_stat/test/data" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
add_executable ( persistence_intervals_test persistence_intervals_test.cpp )
target_link_libraries(persistence_intervals_test ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+
# Unitary tests
add_test(NAME persistence_intervals_test
COMMAND ${CMAKE_CURRENT_BINARY_DIR}/persistence_intervals_test