summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Nerve_GIC/test/CMakeLists.txt')
-rw-r--r--src/Nerve_GIC/test/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/Nerve_GIC/test/CMakeLists.txt b/src/Nerve_GIC/test/CMakeLists.txt
new file mode 100644
index 00000000..77efe043
--- /dev/null
+++ b/src/Nerve_GIC/test/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 2.6)
+project(Graph_induced_complex_tests)
+
+include(GUDHI_test_coverage)
+
+add_executable ( Graph_induced_complex_test_unit test_GIC.cpp )
+target_link_libraries(Graph_induced_complex_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+if (TBB_FOUND)
+ target_link_libraries(Graph_induced_complex_test_unit ${TBB_LIBRARIES})
+endif()
+
+file(COPY data DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+gudhi_add_coverage_test(Graph_induced_complex_test_unit)