summaryrefslogtreecommitdiff
path: root/src/Persistence_representations/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Persistence_representations/example/CMakeLists.txt')
-rw-r--r--src/Persistence_representations/example/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/Persistence_representations/example/CMakeLists.txt b/src/Persistence_representations/example/CMakeLists.txt
index 54d719ac..3142f19b 100644
--- a/src/Persistence_representations/example/CMakeLists.txt
+++ b/src/Persistence_representations/example/CMakeLists.txt
@@ -27,3 +27,22 @@ add_test(NAME Persistence_representations_example_heat_maps
COMMAND $<TARGET_FILE:Persistence_representations_example_heat_maps>)
install(TARGETS Persistence_representations_example_heat_maps DESTINATION bin)
+add_executable ( Sliced_Wasserstein sliced_wasserstein.cpp )
+add_test(NAME Sliced_Wasserstein
+ COMMAND $<TARGET_FILE:Sliced_Wasserstein>)
+install(TARGETS Sliced_Wasserstein DESTINATION bin)
+
+add_executable ( Persistence_weighted_gaussian persistence_weighted_gaussian.cpp )
+add_test(NAME Persistence_weighted_gaussian
+ COMMAND $<TARGET_FILE:Persistence_weighted_gaussian>)
+install(TARGETS Persistence_weighted_gaussian DESTINATION bin)
+
+add_executable ( Persistence_heat_maps_exact persistence_heat_maps_exact.cpp )
+add_test(NAME Persistence_heat_maps_exact
+ COMMAND $<TARGET_FILE:Persistence_heat_maps_exact>)
+install(TARGETS Persistence_heat_maps_exact DESTINATION bin)
+
+add_executable ( Persistence_landscape_on_grid_exact persistence_landscape_on_grid_exact.cpp )
+add_test(NAME Persistence_landscape_on_grid_exact
+ COMMAND $<TARGET_FILE:Persistence_landscape_on_grid_exact>)
+install(TARGETS Persistence_landscape_on_grid_exact DESTINATION bin)