summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2023-07-09 11:24:24 +0200
committerGitHub <noreply@github.com>2023-07-09 11:24:24 +0200
commite3ce21bb937f07b8282dccf4823e2acbdf286d17 (patch)
treecd79bffcb15aef8184d50ce3c17652eff6c37eb0
parent6762e8480c25b6755bd174aedb1bd0ef5f1ad478 (diff)
Bump to v1.6.1 (#496)upstream/latest
-rw-r--r--.appveyor.yml4
-rw-r--r--CHANGELOG3
-rw-r--r--CMakeLists.txt2
-rw-r--r--include/clblast.h4
-rw-r--r--include/clblast_c.h4
5 files changed, 10 insertions, 7 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index c120a9a1..2928f060 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -55,8 +55,8 @@ build_script:
after_build:
- ps: pushd $env:CLBLAST_BUILD
- - 7z a CLBlast-1.6.0-Windows-x64.zip .\install_dir\*
- - ps: mv CLBlast-1.6.0-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
+ - 7z a CLBlast-1.6.1-Windows-x64.zip .\install_dir\*
+ - ps: mv CLBlast-1.6.1-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
artifacts:
- path: '*.zip'
diff --git a/CHANGELOG b/CHANGELOG
index ecd86dec..c63c95da 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,7 @@
Development version (next version)
+-
+
+Version 1.6.1
- Fix pointer error in pyclblast on ARM
- Fix a multithreading bug related to storing objects in the cache
- Added tuned parameters for many devices (see doc/tuning.md)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 414fd0b0..115285ee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,7 +22,7 @@ endif()
project("clblast" C CXX)
set(clblast_VERSION_MAJOR 1)
set(clblast_VERSION_MINOR 6)
-set(clblast_VERSION_PATCH 0)
+set(clblast_VERSION_PATCH 1)
set(clblast_VERSION "${clblast_VERSION_MAJOR}.${clblast_VERSION_MINOR}.${clblast_VERSION_PATCH}")
set(clblast_SOVERSION ${clblast_VERSION_MAJOR})
diff --git a/include/clblast.h b/include/clblast.h
index 6c7481af..44222b42 100644
--- a/include/clblast.h
+++ b/include/clblast.h
@@ -39,10 +39,10 @@
#define PUBLIC_API
#endif
-// Version numbering (v1.6.0)
+// Version numbering (v1.6.1)
#define CLBLAST_VERSION_MAJOR 1
#define CLBLAST_VERSION_MINOR 6
-#define CLBLAST_VERSION_PATCH 0
+#define CLBLAST_VERSION_PATCH 1
namespace clblast {
// =================================================================================================
diff --git a/include/clblast_c.h b/include/clblast_c.h
index c779c556..89c3bc85 100644
--- a/include/clblast_c.h
+++ b/include/clblast_c.h
@@ -34,10 +34,10 @@
#define PUBLIC_API
#endif
-// Version numbering (v1.6.0)
+// Version numbering (v1.6.1)
#define CLBLAST_VERSION_MAJOR 1
#define CLBLAST_VERSION_MINOR 6
-#define CLBLAST_VERSION_PATCH 0
+#define CLBLAST_VERSION_PATCH 1
// The C interface
#ifdef __cplusplus