summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCedric Nugteren <web@cedricnugteren.nl>2023-05-21 20:51:05 +0200
committerGitHub <noreply@github.com>2023-05-21 20:51:05 +0200
commitb0b302889cc786907efb080c4e1beea30d2fa39f (patch)
tree19d9bca3d8cc7f36a99b0b09c131f521c36eef9c
parent036684204e01a28bd8056a8c63c91948f3c39006 (diff)
Update to version 1.6.0 (#475)
-rw-r--r--.appveyor.yml4
-rw-r--r--CHANGELOG5
-rw-r--r--CMakeLists.txt4
-rw-r--r--include/clblast.h6
-rw-r--r--include/clblast_c.h6
5 files changed, 15 insertions, 10 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index a27b3070..c120a9a1 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -55,8 +55,8 @@ build_script:
after_build:
- ps: pushd $env:CLBLAST_BUILD
- - 7z a CLBlast-1.5.3-Windows-x64.zip .\install_dir\*
- - ps: mv CLBlast-1.5.3-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
+ - 7z a CLBlast-1.6.0-Windows-x64.zip .\install_dir\*
+ - ps: mv CLBlast-1.6.0-Windows-x64.zip $env:APPVEYOR_BUILD_FOLDER
artifacts:
- path: '*.zip'
diff --git a/CHANGELOG b/CHANGELOG
index 3fe3208e..3b8b1123 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,7 @@
Development version (next version)
+-
+
+Version 1.6.0
- Modifications to improve performance on Qualcomm Adreno GPUs:
* Unique database entries for specific Adreno devices
* Toggle OpenCL kernel compilation options for Adreno
@@ -11,6 +14,8 @@ Development version (next version)
- Fixes an issue with crashes on Android related to calling clReleaseProgram
- Fixes two small issues in the plotting script
- Fixed a documentation bug in the 'ld' requirements
+- Enabled Github Actions CI builds for testing and releasing
+- Various minor fixes and enhancements
- Added tuned parameters for various devices (see doc/tuning.md)
Version 1.5.3
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e60bf22..414fd0b0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,8 +21,8 @@ endif()
# CMake project details
project("clblast" C CXX)
set(clblast_VERSION_MAJOR 1)
-set(clblast_VERSION_MINOR 5)
-set(clblast_VERSION_PATCH 3)
+set(clblast_VERSION_MINOR 6)
+set(clblast_VERSION_PATCH 0)
set(clblast_VERSION "${clblast_VERSION_MAJOR}.${clblast_VERSION_MINOR}.${clblast_VERSION_PATCH}")
set(clblast_SOVERSION ${clblast_VERSION_MAJOR})
diff --git a/include/clblast.h b/include/clblast.h
index 99364ec6..6c7481af 100644
--- a/include/clblast.h
+++ b/include/clblast.h
@@ -39,10 +39,10 @@
#define PUBLIC_API
#endif
-// Version numbering (v1.5.3)
+// Version numbering (v1.6.0)
#define CLBLAST_VERSION_MAJOR 1
-#define CLBLAST_VERSION_MINOR 5
-#define CLBLAST_VERSION_PATCH 3
+#define CLBLAST_VERSION_MINOR 6
+#define CLBLAST_VERSION_PATCH 0
namespace clblast {
// =================================================================================================
diff --git a/include/clblast_c.h b/include/clblast_c.h
index 07f1fd0c..c779c556 100644
--- a/include/clblast_c.h
+++ b/include/clblast_c.h
@@ -34,10 +34,10 @@
#define PUBLIC_API
#endif
-// Version numbering (v1.5.3)
+// Version numbering (v1.6.0)
#define CLBLAST_VERSION_MAJOR 1
-#define CLBLAST_VERSION_MINOR 5
-#define CLBLAST_VERSION_PATCH 3
+#define CLBLAST_VERSION_MINOR 6
+#define CLBLAST_VERSION_PATCH 0
// The C interface
#ifdef __cplusplus