summaryrefslogtreecommitdiff
path: root/debian/patches/0001-Correct-capitalization-typo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-Correct-capitalization-typo.patch')
-rw-r--r--debian/patches/0001-Correct-capitalization-typo.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/debian/patches/0001-Correct-capitalization-typo.patch b/debian/patches/0001-Correct-capitalization-typo.patch
new file mode 100644
index 00000000..7de2a347
--- /dev/null
+++ b/debian/patches/0001-Correct-capitalization-typo.patch
@@ -0,0 +1,64 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 28 Apr 2021 17:42:34 +0200
+Subject: Correct capitalization typo
+
+CLBLast -> CLBlast
+---
+ CMakeLists.txt | 2 +-
+ include/clblast.h | 2 +-
+ include/clblast_c.h | 2 +-
+ include/clblast_cuda.h | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2d28050..84966bc 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -360,7 +360,7 @@ elseif(CUDA)
+ endif()
+
+ # Installs the config for find_package in dependent projects
+-install(EXPORT CLBlast DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/CLBLast FILE CLBlastConfig.cmake)
++install(EXPORT CLBlast DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/CLBlast FILE CLBlastConfig.cmake)
+
+ # Install pkg-config file on Linux
+ if(UNIX)
+diff --git a/include/clblast.h b/include/clblast.h
+index 296f398..c11e4ab 100644
+--- a/include/clblast.h
++++ b/include/clblast.h
+@@ -710,7 +710,7 @@ StatusCode GemmTempBufferSize(const Layout layout, const Transpose a_transpose,
+ // for the same device. This cache can be cleared to free up system memory or in case of debugging.
+ StatusCode PUBLIC_API ClearCache();
+
+-// The cache can also be pre-initialized for a specific device with all possible CLBLast kernels.
++// The cache can also be pre-initialized for a specific device with all possible CLBlast kernels.
+ // Further CLBlast routine calls will then run at maximum speed.
+ StatusCode PUBLIC_API FillCache(const cl_device_id device);
+
+diff --git a/include/clblast_c.h b/include/clblast_c.h
+index 7f7b1e9..9c2820b 100644
+--- a/include/clblast_c.h
++++ b/include/clblast_c.h
+@@ -1685,7 +1685,7 @@ CLBlastStatusCode PUBLIC_API CLBlastHGemmTempBufferSize(const CLBlastLayout layo
+ // for the same device. This cache can be cleared to free up system memory or in case of debugging.
+ CLBlastStatusCode PUBLIC_API CLBlastClearCache();
+
+-// The cache can also be pre-initialized for a specific device with all possible CLBLast kernels.
++// The cache can also be pre-initialized for a specific device with all possible CLBlast kernels.
+ // Further CLBlast routine calls will then run at maximum speed.
+ CLBlastStatusCode PUBLIC_API CLBlastFillCache(const cl_device_id device);
+
+diff --git a/include/clblast_cuda.h b/include/clblast_cuda.h
+index f6d6372..b62c7ac 100644
+--- a/include/clblast_cuda.h
++++ b/include/clblast_cuda.h
+@@ -677,7 +677,7 @@ StatusCode GemmTempBufferSize(const Layout layout, const Transpose a_transpose,
+ // for the same device. This cache can be cleared to free up system memory or in case of debugging.
+ StatusCode PUBLIC_API ClearCache();
+
+-// The cache can also be pre-initialized for a specific device with all possible CLBLast kernels.
++// The cache can also be pre-initialized for a specific device with all possible CLBlast kernels.
+ // Further CLBlast routine calls will then run at maximum speed.
+ StatusCode PUBLIC_API FillCache(const CUdevice device);
+