summaryrefslogtreecommitdiff
path: root/.appveyor.yml
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-05-27 10:56:49 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-05-27 10:56:49 +0200
commit248452f0958f52185e702bccac2cf1f7e156e159 (patch)
tree2ee4530fce52c8e2458b9c0721e8671a053264f5 /.appveyor.yml
parent8a273e6cd05113ea70117800978d18f4f9ba351f (diff)
Let's try to fix conditional python
Diffstat (limited to '.appveyor.yml')
-rw-r--r--.appveyor.yml22
1 files changed, 14 insertions, 8 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 1334004b..3cf5d71b 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -24,7 +24,7 @@ environment:
- target: Python
CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON
- PYTHON: "C:\\Python36-x64"
+ PYTHON: "C:\\Python37-x64"
cache:
@@ -37,15 +37,21 @@ init:
install:
- vcpkg install tbb:x64-windows boost-disjoint-sets:x64-windows boost-serialization:x64-windows boost-date-time:x64-windows boost-system:x64-windows boost-filesystem:x64-windows boost-units:x64-windows boost-thread:x64-windows boost-program-options:x64-windows eigen3:x64-windows cgal:x64-windows
- - if "%target%"=="Python" "%PYTHON%\\python.exe --version"
- - if "%target%"=="Python" "%PYTHON%\\python.exe -m pip install -U pip setuptools numpy matplotlib scipy Cython pytest"
+ - if [%target%]==[Python] (
+ SET PATH=%PYTHON%;%PYTHON%\\Scripts;%PATH%
+ python --version
+ pip version
+ pip install -U setuptools numpy matplotlib scipy Cython pytest )
build_script:
- mkdir build
- cd build
- cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% -DCMAKE_TOOLCHAIN_FILE=c:/Tools/vcpkg/scripts/buildsystems/vcpkg.cmake ..
- - if NOT "%target%"=="Python" MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64
- - if NOT "%target%"=="Python" ctest -j 1 -C Release -E diff_files
- - if "%target%"=="Python" cd src/cython
- - if "%target%"=="Python" "%PYTHON%\\python.exe setup.py install"
- - if "%target%"=="Python" MSBuild RUN_TESTS.vcxproj
+ - if [%target%]==[Python] (
+ cd src/cython
+ python setup.py install
+ MSBuild RUN_TESTS.vcxproj
+ ) else (
+ MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64
+ ctest -j 1 -C Release -E diff_files
+ )