summaryrefslogtreecommitdiff
path: root/.appveyor.yml
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-05-24 17:41:27 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-05-24 17:41:27 +0200
commit57d63634e54c1316bd150a10298a61c41b904429 (patch)
tree8a7563bfbc323e51c38ae1cff2baa786f6b68806 /.appveyor.yml
parent433a12c0fd70af56b1464eb79aaad748080c579a (diff)
Try to fix python compilation and tests
Diffstat (limited to '.appveyor.yml')
-rw-r--r--.appveyor.yml7
1 files changed, 5 insertions, 2 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 95dc7a3e..fe9c7a8e 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -40,5 +40,8 @@ build_script:
- mkdir build
- cd build
- cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% -DCMAKE_TOOLCHAIN_FILE=c:/Tools/vcpkg/scripts/buildsystems/vcpkg.cmake ..
- - MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64
- - ctest -j 1 -C Release -E diff_files
+ - if NOT "%target%"=="Python" MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64
+ - if NOT "%target%"=="Python" ctest -j 1 -C Release -E diff_files
+ - if "%target%"=="Python" cd src/cython
+ - if "%target%"=="Python" python setup.py install
+ - if "%target%"=="Python" MSBuild RUN_TESTS.vcxproj