summaryrefslogtreecommitdiff
path: root/.appveyor.yml
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-05-27 11:04:57 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-05-27 11:04:57 +0200
commit5a9a00430798732c122e9a8ff98890aaa30a79dc (patch)
tree130afc0af81d9ba6058044e0442a22f9aafde054 /.appveyor.yml
parent248452f0958f52185e702bccac2cf1f7e156e159 (diff)
Let's try to fix conditional
Diffstat (limited to '.appveyor.yml')
-rw-r--r--.appveyor.yml12
1 files changed, 6 insertions, 6 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 3cf5d71b..6e999458 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -38,9 +38,9 @@ init:
install:
- vcpkg install tbb:x64-windows boost-disjoint-sets:x64-windows boost-serialization:x64-windows boost-date-time:x64-windows boost-system:x64-windows boost-filesystem:x64-windows boost-units:x64-windows boost-thread:x64-windows boost-program-options:x64-windows eigen3:x64-windows cgal:x64-windows
- if [%target%]==[Python] (
- SET PATH=%PYTHON%;%PYTHON%\\Scripts;%PATH%
- python --version
- pip version
+ SET PATH=%PYTHON%;%PYTHON%\\Scripts;%PATH% &
+ python --version &
+ pip version &
pip install -U setuptools numpy matplotlib scipy Cython pytest )
build_script:
@@ -48,10 +48,10 @@ build_script:
- cd build
- cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% -DCMAKE_TOOLCHAIN_FILE=c:/Tools/vcpkg/scripts/buildsystems/vcpkg.cmake ..
- if [%target%]==[Python] (
- cd src/cython
- python setup.py install
+ cd src/cython &
+ python setup.py install &
MSBuild RUN_TESTS.vcxproj
) else (
- MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64
+ MSBuild GUDHIdev.sln /m /p:Configuration=Release /p:Platform=x64 &
ctest -j 1 -C Release -E diff_files
)