summaryrefslogtreecommitdiff
path: root/.appveyor.yml
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-06-05 11:06:04 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2019-06-05 11:06:04 +0200
commit84e40389f77bdb0a614efb947469d8920c723738 (patch)
tree6ffeae729ec7d7cc2ad958f1aeeda37ca07d0613 /.appveyor.yml
parent7705d6ceac3d8a302b1950f77565f44a15122a30 (diff)
Add some debug traces
Diffstat (limited to '.appveyor.yml')
-rw-r--r--.appveyor.yml11
1 files changed, 6 insertions, 5 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 294744b1..1048328e 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -26,7 +26,7 @@ environment:
# PYTHON: "C:\\Python37-x64"
- target: Python
- CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DGMP_INCLUDE_DIR="c:/Tools/vcpkg/installed/x64-windows/include" -DGMP_LIBRARIES="c:/Tools/vcpkg/installed/x64-windows/lib/mpir.lib" -DMPFR_INCLUDE_DIR="c:/Tools/vcpkg/installed/x64-windows/include" -DMPFR_LIBRARIES="c:/Tools/vcpkg/installed/x64-windows/lib/mpir.lib"
+ CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DGMP_INCLUDE_DIR="c:/Tools/vcpkg/installed/x64-windows/include" -DGMP_LIBRARIES="c:/Tools/vcpkg/installed/x64-windows/lib/mpir.lib"
PYTHON: "C:\\Python37-x64"
@@ -42,10 +42,10 @@ install:
- vcpkg install tbb:x64-windows boost-disjoint-sets:x64-windows boost-serialization:x64-windows boost-date-time:x64-windows boost-system:x64-windows boost-filesystem:x64-windows boost-units:x64-windows boost-thread:x64-windows boost-program-options:x64-windows eigen3:x64-windows mpfr:x64-windows mpir:x64-windows cgal:x64-windows
- SET PATH=%PYTHON%;%PYTHON%\\Scripts;%PATH%
- CALL "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\Build\vcvarsall.bat" amd64
- - if [%target%]==[Python] ( python --version &
- pip --version &
- python -m pip install --upgrade pip &
- pip install -U setuptools numpy matplotlib scipy Cython pytest )
+ - python --version
+ - pip --version
+ - python -m pip install --upgrade pip
+ - pip install -U setuptools numpy matplotlib scipy Cython pytest )
build_script:
- mkdir build
@@ -53,6 +53,7 @@ build_script:
- cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% -DCMAKE_TOOLCHAIN_FILE=c:/Tools/vcpkg/scripts/buildsystems/vcpkg.cmake ..
- if [%target%]==[Python] (
cd src/cython &
+ Type setup.py &
python setup.py install &
MSBuild RUN_TESTS.vcxproj
) else (