summaryrefslogtreecommitdiff
path: root/.circleci/config.yml
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-05-20 08:42:23 +0200
committerGard Spreemann <gspr@nonempty.org>2020-05-20 08:42:23 +0200
commit9b3079646ee3f6a494b83e864b3e10b8a93597d0 (patch)
tree63ecae8cf0d09b72907805e68f19765c7dd9694a /.circleci/config.yml
parent81816dae256a9f3c0653b1d21443c3c32da7a974 (diff)
parent97e889f34e929f3c2306803b6c37b57926bd1245 (diff)
Merge tag 'tags/gudhi-release-3.2.0' into dfsg/latest
Diffstat (limited to '.circleci/config.yml')
-rw-r--r--.circleci/config.yml11
1 files changed, 7 insertions, 4 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index f4073746..40ddc08e 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -45,12 +45,13 @@ jobs:
python:
docker:
- image: gudhi/ci_for_gudhi:latest
- parallelism: 4
steps:
- checkout
- run:
name: Build and test python module. Generates and tests the python documentation
command: |
+ git submodule init
+ git submodule update
mkdir build;
cd build;
cmake -DUSER_VERSION_DIR=version ..;
@@ -60,12 +61,12 @@ jobs:
cd build;
cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 ..;
cd python;
- python3 setup.py build_ext -j 4 --inplace;
+ python3 setup.py build_ext -j 2 --inplace;
make sphinx;
cp -R sphinx /tmp/sphinx;
python3 setup.py install;
python3 setup.py clean --all;
- ctest -j 4 --output-on-failure;
+ ctest -j 2 --output-on-failure;
- store_artifacts:
path: /tmp/sphinx
@@ -78,6 +79,8 @@ jobs:
- run:
name: Generates the C++ documentation with doxygen
command: |
+ git submodule init
+ git submodule update
mkdir build;
cd build;
cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=OFF -DUSER_VERSION_DIR=version ..;
@@ -97,4 +100,4 @@ workflows:
- tests
- utils
- python
- - doxygen \ No newline at end of file
+ - doxygen