summaryrefslogtreecommitdiff
path: root/.circleci
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-08-20 09:35:31 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-08-20 09:35:31 +0200
commit37786db094d0251bf070215e89e4446384dbe871 (patch)
treeb3207acb17a8fe22bbfbfedc30990d9b3087a2c9 /.circleci
parent4a572af654afc22e2f5c26766f611b1918313509 (diff)
Let's clean fail
Diffstat (limited to '.circleci')
-rw-r--r--.circleci/config.yml12
1 files changed, 6 insertions, 6 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index eca9f91e..129fdc23 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -57,19 +57,19 @@ jobs:
cmake -DUSER_VERSION_DIR=version ..;
make user_version;
cd version;
- mkdir build;
- cd build;
- cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 ..;
+ cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 .;
cd python;
python3 setup.py build_ext --inplace;
make sphinx;
cp -R sphinx /tmp/sphinx;
python3 setup.py install;
- python3 setup.py clean --all;
- ctest -j 2 --output-on-failure;
-
+ python3 setup.py clean --all || true;
+ python3 -B -m pytest test/*.py --cov-report html --cov=gudhi;
+ cp -R htmlcov /tmp/htmlcov;
- store_artifacts:
path: /tmp/sphinx
+ - store_artifacts:
+ path: /tmp/htmlcov
doxygen:
docker: