summaryrefslogtreecommitdiff
path: root/.circleci
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-08-19 11:34:06 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-08-19 11:34:06 +0200
commit6128a88a6780af29825c73af0e32100e93c2f0b5 (patch)
tree2cf28870f53ccec1b5093c7c2e8a461d08aef1dd /.circleci
parent0e620832b3b6d2e1027ead9730dce872983dd2ce (diff)
python code coverage on python circleci target. Fix language_level cython warning
Diffstat (limited to '.circleci')
-rw-r--r--.circleci/config.yml10
1 files changed, 6 insertions, 4 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index b04efd52..f8dae062 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -57,20 +57,22 @@ jobs:
cmake -DUSER_VERSION_DIR=version ..;
make user_version;
cd version;
- mkdir build;
- cd build;
- cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 ..;
+ cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 .;
cd python;
python3 setup.py build_ext --inplace;
make sphinx;
cp -R sphinx /tmp/sphinx;
python3 setup.py install;
python3 setup.py clean --all;
- ctest -j 2 --output-on-failure;
+ python3 -B -m pytest test/*.py --cov-report html --cov=gudhi;
+ cp -R htmlcov /tmp/htmlcov;
- store_artifacts:
path: /tmp/sphinx
+ - store_artifacts:
+ path: /tmp/htmlcov
+
doxygen:
docker:
- image: gudhi/ci_for_gudhi:latest