summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Rouvreau <vincent.rouvreau@inria.fr>2022-06-13 14:41:46 +0200
committerVincent Rouvreau <vincent.rouvreau@inria.fr>2022-06-13 14:41:46 +0200
commit610ed41d9465f3b8fc56535368b467e217399ac1 (patch)
tree52b27a204232626e6f97290d996618979226b6b8
parenteb1e6f67cf94e2f3991d9092131621e09b1ee257 (diff)
parent7fff2e5e725ced71da812d9f0bede1c8e0666e2e (diff)
Merge remote-tracking branch 'albert/feature/bug__documentation_only' into doxygen_only
-rw-r--r--CMakeLists.txt13
-rw-r--r--src/common/doc/installation.h11
2 files changed, 18 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac877eea..47d87cd1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,6 @@
+
+option(WITH_GUDHI_CPP_DOCUMENTATION_ONLY "Build only the GUDHI C++ documentation (with doxygen)." OFF)
+
cmake_minimum_required(VERSION 3.5)
project(GUDHIdev)
@@ -13,8 +16,10 @@ set(GUDHI_MISSING_MODULES "" CACHE INTERNAL "GUDHI_MISSING_MODULES")
# This variable is used by Cython CMakeLists.txt and by GUDHI_third_party_libraries to know its path
set(GUDHI_PYTHON_PATH "src/python")
-# For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
-include(GUDHI_third_party_libraries NO_POLICY_SCOPE)
+if (NOT WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
+ # For third parties libraries management - To be done last as CGAL updates CMAKE_MODULE_PATH
+ include(GUDHI_third_party_libraries NO_POLICY_SCOPE)
+endif()
include(GUDHI_compilation_flags)
@@ -52,7 +57,9 @@ foreach(GUDHI_MODULE ${GUDHI_MODULES})
endforeach()
endforeach()
-add_subdirectory(src/GudhUI)
+if (NOT WITH_GUDHI_CPP_DOCUMENTATION_ONLY)
+ add_subdirectory(src/GudhUI)
+endif()
if (WITH_GUDHI_PYTHON)
# specific for cython module
diff --git a/src/common/doc/installation.h b/src/common/doc/installation.h
index 24a7fc7a..131130f8 100644
--- a/src/common/doc/installation.h
+++ b/src/common/doc/installation.h
@@ -41,12 +41,17 @@ make \endverbatim
* program). If some of the tests are failing, please send us the result of the following command:
* \verbatim ctest --output-on-failure \endverbatim
*
- * \subsection documentationgeneration Documentation
- * To generate the documentation, <a target="_blank" href="http://www.doxygen.org/">Doxygen</a> is required.
- * Run the following command in a terminal:
+ * \subsection documentationgeneration C++ documentation
+ * To generate the C++ documentation, for this the <a target="_blank" href="http://www.doxygen.org/">doxygen</a> program
+ * is required, run the following command in a terminal:
* \verbatim make doxygen \endverbatim
* Documentation will be generated in a folder named <code>html</code>.
*
+ * In case there is not a full setup present and only the documentation should be build the following command sequence
+ * can be used:
+\verbatim cmake -DWITH_GUDHI_CPP_DOCUMENTATION_ONLY=ON ..
+make doxygen\endverbatim
+ *
* \subsection helloworld Hello world !
* The <a target="_blank" href="https://github.com/GUDHI/hello-gudhi-world">Hello world for GUDHI</a>
* project is an example to help developers to make their own C++ project on top of the GUDHI library.