summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2022-01-14 21:07:02 +0100
committerGard Spreemann <gspr@nonempty.org>2022-01-15 14:18:45 +0100
commit146a1e2f5bafefaf8782e3e8c94223049987b80f (patch)
tree60f8faa276826d00396611ee5c075c221859f8f0
parentf46ec9393f413b675030f22c855f53ffa4cb216c (diff)
Build the Python modules by direct setup.py invocationdebian/3.5.0+dfsg-1
The upstream wrapping of setup.py into the outer CMake system used for the rest of the tree is getting a bit unwieldy.
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules9
2 files changed, 5 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 4d9a4ec7..04eb8652 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,7 @@ gudhi (3.5.0+dfsg-1) unstable; urgency=medium
upstream.
* Move HTML documentation to libgudhi-dev's doc directory.
* Add patch to avoid building Doxygen docs from source root.
+ * Don't build Python modules using CMake.
-- Gard Spreemann <gspr@nonempty.org> Fri, 14 Jan 2022 19:28:42 +0100
diff --git a/debian/rules b/debian/rules
index 05677e07..ae189c06 100755
--- a/debian/rules
+++ b/debian/rules
@@ -54,7 +54,8 @@ override_dh_auto_configure:
override_dh_auto_build-arch:
dh_auto_build $(DHFLAGS) --builddirectory=build/userversion
for py3ver in $(PY3VERS) ; do \
- dh_auto_build $(DHFLAGS) --builddirectory=build-py$$py3ver/userversion ; \
+ cd build-py$$py3ver/userversion/src/python ; \
+ /usr/bin/python$$py3ver setup.py build ; \
done
override_dh_auto_build-indep:
@@ -67,9 +68,6 @@ override_dh_auto_test-arch:
# but see #901678.
ifeq (, $(filter nocheck,$(DEB_BUILD_MAINT_OPTIONS)))
dh_auto_test $(DHFLAGS) --no-parallel --builddirectory=build/userversion
- for py3ver in $(PY3VERS) ; do \
- dh_auto_test $(DHFLAGS) --no-parallel --builddirectory=build-py$$py3ver/userversion ; \
- done
else
@echo "Skipping tests due to nocheck flag."
endif
@@ -77,7 +75,8 @@ endif
override_dh_auto_install-arch:
dh_auto_install $(DHFLAGS) --builddirectory=build/userversion
for py3ver in $(PY3VERS) ; do \
- dh_auto_install $(DHFLAGS) --builddirectory=build-py$$py3ver/userversion ; \
+ cd build-py$$py3ver/userversion/src/python ; \
+ /usr/bin/python$$py3ver setup.py install --root=../../../../debian/tmp --single-version-externally-managed --install-layout=deb ; \
done
mv $(TMPBIN)/Nerve \