summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-10-16 11:12:49 +0200
committerGard Spreemann <gspr@nonempty.org>2020-10-16 11:56:50 +0200
commit99cc26ac3540e59d193325db9d17b0886e78e844 (patch)
tree855936447995b04c9407d580519ce0f6ba300fab
parent4250a7228e9f2a5abf3dedda41820d0fc87d4efe (diff)
Fix binary-all FTBFS.debian/3.3.0+dfsg-3
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules16
2 files changed, 14 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 3641763b..a3795abc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+gudhi (3.3.0+dfsg-3) unstable; urgency=medium
+
+ * Fix binary-all FTBFS. (Closes: #972267)
+
+ -- Gard Spreemann <gspr@nonempty.org> Fri, 16 Oct 2020 11:11:36 +0200
+
gudhi (3.3.0+dfsg-2) unstable; urgency=medium
* Treat all Python versions the same way during build.
diff --git a/debian/rules b/debian/rules
index 9e16dc1b..f3ee24bb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -59,7 +59,6 @@ override_dh_auto_build-arch:
override_dh_auto_build-indep:
make -C build doxygen
- dh_auto_build $(DHFLAGS) --builddirectory=build/userversion
override_dh_auto_test-indep:
@@ -75,18 +74,12 @@ else
@echo "Skipping tests due to nocheck flag."
endif
-override_dh_auto_install:
- find src -type f -path '*/example/*' \( -name '*.cpp' -o \( -name '*.txt' -a ! -iname 'cmake*' \) \) -exec sh -c 'name=$$(echo $$0 | sed s/src\\/// | sed s/example\\///); install -D -m 644 $$0 debian/tmp/usr/share/doc/libgudhi-examples/$$name' {} \;
-
+override_dh_auto_install-arch:
dh_auto_install $(DHFLAGS) --builddirectory=build/userversion
for py3ver in $(PY3VERS) ; do \
dh_auto_install $(DHFLAGS) --builddirectory=build-py$$py3ver/userversion ; \
done
- # Remove installed information about Miniball header.
- rm build/userversion/include/gudhi/Miniball.COPYRIGHT
- rm build/userversion/include/gudhi/Miniball.README
-
mv $(TMPBIN)/Nerve \
$(TMPBIN)/gudhi-nerve
mv $(TMPBIN)/VoronoiGIC \
@@ -124,6 +117,13 @@ override_dh_auto_install:
mv $(TMPBIN)/GudhUI $(TMPBIN)/gudhui
+override_dh_auto_install-indep:
+ find src -type f -path '*/example/*' \( -name '*.cpp' -o \( -name '*.txt' -a ! -iname 'cmake*' \) \) -exec sh -c 'name=$$(echo $$0 | sed s/src\\/// | sed s/example\\///); install -D -m 644 $$0 debian/tmp/usr/share/doc/libgudhi-examples/$$name' {} \;
+
+ # Remove installed information about Miniball header.
+ rm build/userversion/include/gudhi/Miniball.COPYRIGHT
+ rm build/userversion/include/gudhi/Miniball.README
+
override_dh_compress:
dh_compress -X.cpp