summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-12-29 11:01:03 +0100
committerGard Spreemann <gspr@nonempty.org>2020-12-29 12:02:42 +0100
commitc108cc1b75a4feac787aa60ca1263208068149cb (patch)
tree2fffb6cb0452f36225030b1f588642032ba10ec6
parent0635032c91af3e9e56e8385f2ef9fc5961fa9280 (diff)
Patch to fix building with CGAL 5.2.debian/3.4.0+dfsg-2
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/0008-Fix-building-with-CGAL-5.2.patch36
-rw-r--r--debian/patches/series1
3 files changed, 43 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 3b2fb9f8..86c376a7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+gudhi (3.4.0+dfsg-2) unstable; urgency=medium
+
+ * Add patch to fix building with CGAL 5.2. (Closes: #978191)
+
+ -- Gard Spreemann <gspr@nonempty.org> Tue, 29 Dec 2020 11:00:12 +0100
+
gudhi (3.4.0+dfsg-1) unstable; urgency=medium
* New upstream version.
diff --git a/debian/patches/0008-Fix-building-with-CGAL-5.2.patch b/debian/patches/0008-Fix-building-with-CGAL-5.2.patch
new file mode 100644
index 00000000..ae0ac00b
--- /dev/null
+++ b/debian/patches/0008-Fix-building-with-CGAL-5.2.patch
@@ -0,0 +1,36 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Tue, 29 Dec 2020 12:01:36 +0100
+Subject: Fix building with CGAL 5.2.
+
+---
+ src/Tangential_complex/include/gudhi/Tangential_complex.h | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/src/Tangential_complex/include/gudhi/Tangential_complex.h b/src/Tangential_complex/include/gudhi/Tangential_complex.h
+index f007bdd..f3491f9 100644
+--- a/src/Tangential_complex/include/gudhi/Tangential_complex.h
++++ b/src/Tangential_complex/include/gudhi/Tangential_complex.h
+@@ -954,7 +954,11 @@ class Tangential_complex {
+
+ // Triangulation's traits functor & objects
+ typename Tr_traits::Compute_weight_d point_weight = local_tr_traits.compute_weight_d_object();
++#if CGAL_VERSION_NR < 1050200000
+ typename Tr_traits::Power_center_d power_center = local_tr_traits.power_center_d_object();
++#else
++ typename Tr_traits::Construct_power_sphere_d power_center = local_tr_traits.construct_power_sphere_d_object();
++#endif
+
+ //***************************************************
+ // Build a minimal triangulation in the tangent space
+@@ -1100,7 +1104,11 @@ class Tangential_complex {
+ std::size_t closest_pt_index = updated_pts_ds.k_nearest_neighbors(center_point, 1, false).begin()->first;
+
+ typename K::Construct_weighted_point_d k_constr_wp = m_k.construct_weighted_point_d_object();
++#if CGAL_VERSION_NR < 1050200000
+ typename K::Power_distance_d k_power_dist = m_k.power_distance_d_object();
++#else
++ typename K::Compute_power_product_d k_power_dist = m_k.compute_power_product_d_object();
++#endif
+
+ // Construct a weighted point equivalent to the star sphere
+ Weighted_point star_sphere = k_constr_wp(compute_perturbed_point(i), m_squared_star_spheres_radii_incl_margin[i]);
diff --git a/debian/patches/series b/debian/patches/series
index adeb35f7..cc576f3b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@
0005-Disable-Sphinx.patch
0006-Install-Python-module-in-correct-location.patch
0007-Move-towards-reproducible-builds.patch
+0008-Fix-building-with-CGAL-5.2.patch