summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2020-02-06 15:35:16 +0100
committerGitHub <noreply@github.com>2020-02-06 15:35:16 +0100
commit055fda8507fde336a21169f10b3fd0782886e472 (patch)
tree138329776b351828f2674ca7f71b2e2aa0dbe276
parent4ba35f8120c897b378b84e6f0e4b955d254f683e (diff)
parent3f5420aa5d5c9de1cd0cfe6ea1eb57a20a212c7c (diff)
Merge pull request #221 from VincentRouvreau/ci_shall_test_install
Install version, clean compilation and test the installed version
-rw-r--r--.circleci/config.yml10
1 files changed, 7 insertions, 3 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index 5e45bc14..f4073746 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -45,6 +45,7 @@ jobs:
python:
docker:
- image: gudhi/ci_for_gudhi:latest
+ parallelism: 4
steps:
- checkout
- run:
@@ -58,10 +59,13 @@ jobs:
mkdir build;
cd build;
cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 ..;
- make all;
- ctest --output-on-failure;
+ cd python;
+ python3 setup.py build_ext -j 4 --inplace;
make sphinx;
- cp -R python/sphinx /tmp/sphinx;
+ cp -R sphinx /tmp/sphinx;
+ python3 setup.py install;
+ python3 setup.py clean --all;
+ ctest -j 4 --output-on-failure;
- store_artifacts:
path: /tmp/sphinx