summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-03-29 19:56:28 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-03-29 19:56:28 +0000
commit1ab1897554a46a440e52a76e689aa2923d56053d (patch)
tree4d0c4c4c93f27aa6b3e3498c54167fc72585900f
parent065e7c483af571a275d48a637aa3b77d7efe52c9 (diff)
Small modifications
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/ST_cythonize@2286 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 34dc48a00ed8270967952b8763006b17f96a13e7
-rw-r--r--src/cython/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/cython/CMakeLists.txt b/src/cython/CMakeLists.txt
index 7375737c..233a557e 100644
--- a/src/cython/CMakeLists.txt
+++ b/src/cython/CMakeLists.txt
@@ -14,7 +14,8 @@ macro( find_the_lib placeholder THE_LIBS )
endforeach(THE_LIB ${THE_LIBS})
endmacro( find_the_lib )
-# Find the correct Python interpreter. Can be set with -DPYTHON_EXECUTABLE=/usr/bin/python3 for instance.
+# Find the correct Python interpreter.
+# Can be set with -DPYTHON_EXECUTABLE=/usr/bin/python3 or -DPython_ADDITIONAL_VERSIONS=3 for instance.
if(PYTHON_EXECUTABLE)
if(NOT EXISTS "${PYTHON_EXECUTABLE}")
message(FATAL_ERROR "ERROR: ${PYTHON_EXECUTABLE} does not exist.")
@@ -23,6 +24,7 @@ endif(PYTHON_EXECUTABLE)
find_package(PythonInterp)
if(PYTHONINTERP_FOUND)
+ # Default found version 2
if(PYTHON_VERSION_MAJOR EQUAL 2)
FIND_PROGRAM(CYTHON_PATH cython)
# Unitary tests are available through py.test