summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpdlotko <pdlotko@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-03-31 13:22:29 +0000
committerpdlotko <pdlotko@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-03-31 13:22:29 +0000
commit318c309206f1cffcc17c9333bb6ac9e2f90b7610 (patch)
tree014b65139bf0d0ad9dc447116e9721bf9ba02a78
parent084dc68706f1c1866d279dc75b6de92e81885844 (diff)
solved problem with cmake.
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/gudhi_stat@2294 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 34fc791c80d9e66ab18e992f73bbf3252b3d5e1e
-rw-r--r--CMakeLists.txt5
-rw-r--r--src/Gudhi_stat/include/gudhi/bootstrap.h17
-rw-r--r--src/Gudhi_stat/utilities/CMakeLists.txt103
-rw-r--r--src/Gudhi_stat/utilities/Hausdorff_subsampling.cpp (renamed from src/Gudhi_stat/utilities/Hausdorff_bootstrap.cpp)41
-rw-r--r--src/Gudhi_stat/utilities/persistence_heat_maps/CMakeLists.txt31
-rw-r--r--src/Gudhi_stat/utilities/persistence_intervals/CMakeLists.txt22
-rw-r--r--src/Gudhi_stat/utilities/persistence_intervals/plot_persistence_intervals.cpp4
-rw-r--r--src/Gudhi_stat/utilities/persistence_landscapes/CMakeLists.txt21
-rw-r--r--src/Gudhi_stat/utilities/persistence_landscapes_on_grid/CMakeLists.txt22
-rw-r--r--src/Gudhi_stat/utilities/persistence_vectors/CMakeLists.txt20
10 files changed, 177 insertions, 109 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 488f1d62..bb412421 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -146,6 +146,11 @@ else()
add_subdirectory(src/Gudhi_stat/test)
add_subdirectory(src/Gudhi_stat/example)
add_subdirectory(src/Gudhi_stat/utilities)
+ add_subdirectory(src/Gudhi_stat/utilities/persistence_heat_maps)
+ add_subdirectory(src/Gudhi_stat/utilities/persistence_intervals)
+ add_subdirectory(src/Gudhi_stat/utilities/persistence_landscapes)
+ add_subdirectory(src/Gudhi_stat/utilities/persistence_landscapes_on_grid)
+ add_subdirectory(src/Gudhi_stat/utilities/persistence_vectors)
# data points generator
add_subdirectory(data/points/generator)
diff --git a/src/Gudhi_stat/include/gudhi/bootstrap.h b/src/Gudhi_stat/include/gudhi/bootstrap.h
index 629240ed..dde08130 100644
--- a/src/Gudhi_stat/include/gudhi/bootstrap.h
+++ b/src/Gudhi_stat/include/gudhi/bootstrap.h
@@ -1,4 +1,4 @@
-/* This file is part of the Gudhi Library. The Gudhi library
+/* Thicharacteristic_of_all_pointss file is part of the Gudhi Library. The Gudhi library
* (Geometric Understanding in Higher Dimensions) is a generic C++
* library for computational topology.
*
@@ -135,14 +135,21 @@ double bootstrap( size_t number_of_points , CharacteristicFunction f , DistanceB
// );
// #endif
+ //size_t position_of_quantile = floor(2*(1-quantile)*vector_of_distances.size());
+
+
size_t position_of_quantile = floor(quantile*vector_of_distances.size());
if ( position_of_quantile ) --position_of_quantile;
if ( dbg )
{
- std::cout << "position_of_quantile : " << position_of_quantile << ", and here is the array : " << std::endl;
+ std::cerr << "quantile : " << quantile << std::endl;
+ std::cerr << "position_of_quantile : " << position_of_quantile << std::endl;
+
+ std::sort( vector_of_distances.begin() , vector_of_distances.end() );
+ //std::cout << "position_of_quantile : " << position_of_quantile << ", and here is the array : " << std::endl;
for ( size_t i = 0 ; i != vector_of_distances.size() ; ++i )
{
- std::cout << vector_of_distances[i] << std::endl;
+ std::cout << vector_of_distances[i] << " " ;
}
std::cout << std::endl;
}
@@ -150,6 +157,10 @@ double bootstrap( size_t number_of_points , CharacteristicFunction f , DistanceB
//now we need to sort the vector_of_distances and find the quantile:
std::nth_element (vector_of_distances.begin(), vector_of_distances.begin()+position_of_quantile, vector_of_distances.end());
+
+ //for Hausdorff bootrstra I have to multily it by 2.
+ //In case of other bootsraps, I do not have to do it. We need a special variable saying if Ineed this multiplication or not.//This should be done outside the bootstrap, since the fact hat we need it do not come from bootstrab, but from geometry of bottleneck distance
+
if ( dbg )std::cout << "Result : " << vector_of_distances[ position_of_quantile ] << std::endl;
return vector_of_distances[ position_of_quantile ];
diff --git a/src/Gudhi_stat/utilities/CMakeLists.txt b/src/Gudhi_stat/utilities/CMakeLists.txt
index b7989a96..235d5d2e 100644
--- a/src/Gudhi_stat/utilities/CMakeLists.txt
+++ b/src/Gudhi_stat/utilities/CMakeLists.txt
@@ -3,103 +3,6 @@ project(GUDHI_STAT)
-#persitence diagrams
-add_executable ( persistence_intervals/plot_persistence_intervals persistence_intervals/plot_persistence_intervals.cpp )
-target_link_libraries( persistence_intervals/plot_persistence_intervals ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_intervals/compute_birth_death_range_in_persistence_diagram persistence_intervals/compute_birth_death_range_in_persistence_diagram.cpp )
-target_link_libraries( persistence_intervals/compute_birth_death_range_in_persistence_diagram ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_intervals/compute_number_of_dominant_intervals persistence_intervals/compute_number_of_dominant_intervals.cpp )
-target_link_libraries( persistence_intervals/compute_number_of_dominant_intervals ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_intervals/plot_histogram_of_intervals_lengths persistence_intervals/plot_histogram_of_intervals_lengths.cpp )
-target_link_libraries( persistence_intervals/plot_histogram_of_intervals_lengths ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_intervals/plot_persistence_Betti_numebrs persistence_intervals/plot_persistence_Betti_numebrs.cpp )
-target_link_libraries( persistence_intervals/plot_persistence_Betti_numebrs ${Boost_SYSTEM_LIBRARY})
-
-#when we have bottleneck and wasserstein distance computations, add suitable programs here.
-
-
-#persitence landscapes
-add_executable ( persistence_landscapes/average_landscapes persistence_landscapes/average_landscapes.cpp )
-target_link_libraries(persistence_landscapes/average_landscapes ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_landscapes/create_landscapes persistence_landscapes/create_landscapes.cpp )
-target_link_libraries(persistence_landscapes/create_landscapes ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_landscapes/plot_landscapes persistence_landscapes/plot_landscapes.cpp )
-target_link_libraries(persistence_landscapes/plot_landscapes ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_landscapes/compute_distance_of_landscapes persistence_landscapes/compute_distance_of_landscapes.cpp )
-target_link_libraries(persistence_landscapes/compute_distance_of_landscapes ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_landscapes/compute_scalar_product_of_landscapes persistence_landscapes/compute_scalar_product_of_landscapes.cpp )
-target_link_libraries(persistence_landscapes/compute_scalar_product_of_landscapes ${Boost_SYSTEM_LIBRARY})
-
-#persitence landscapes on a grid
-add_executable ( persistence_landscapes_on_grid/average_landscapes_on_grid persistence_landscapes_on_grid/average_landscapes_on_grid.cpp )
-target_link_libraries(persistence_landscapes_on_grid/average_landscapes_on_grid ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_landscapes_on_grid/create_landscapes_on_grid persistence_landscapes_on_grid/create_landscapes_on_grid.cpp )
-target_link_libraries(persistence_landscapes_on_grid/create_landscapes_on_grid ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_landscapes_on_grid/plot_landscapes_on_grid persistence_landscapes_on_grid/plot_landscapes_on_grid.cpp )
-target_link_libraries(persistence_landscapes_on_grid/plot_landscapes_on_grid ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_landscapes_on_grid/compute_distance_of_landscapes_on_grid persistence_landscapes_on_grid/compute_distance_of_landscapes_on_grid.cpp )
-target_link_libraries(persistence_landscapes_on_grid/compute_distance_of_landscapes_on_grid ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_landscapes_on_grid/compute_scalar_product_of_landscapes_on_grid persistence_landscapes_on_grid/compute_scalar_product_of_landscapes_on_grid.cpp )
-target_link_libraries(persistence_landscapes_on_grid/compute_scalar_product_of_landscapes_on_grid ${Boost_SYSTEM_LIBRARY})
-
-#persitence heat maps
-add_executable ( persistence_heat_maps/average_persistence_heat_maps persistence_heat_maps/average_persistence_heat_maps.cpp )
-target_link_libraries(persistence_heat_maps/average_persistence_heat_maps ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_heat_maps/create_persistence_heat_maps persistence_heat_maps/create_persistence_heat_maps.cpp )
-target_link_libraries(persistence_heat_maps/create_persistence_heat_maps ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_heat_maps/plot_persistence_heat_map persistence_heat_maps/plot_persistence_heat_map.cpp )
-target_link_libraries(persistence_heat_maps/plot_persistence_heat_map ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_heat_maps/compute_distance_of_persistence_heat_maps persistence_heat_maps/compute_distance_of_persistence_heat_maps.cpp )
-target_link_libraries(persistence_heat_maps/compute_distance_of_persistence_heat_maps ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_heat_maps/compute_scalar_product_of_persistence_heat_maps persistence_heat_maps/compute_scalar_product_of_persistence_heat_maps.cpp )
-target_link_libraries(persistence_heat_maps/compute_scalar_product_of_persistence_heat_maps ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_heat_maps/create_pssk persistence_heat_maps/create_pssk.cpp )
-target_link_libraries(persistence_heat_maps/create_pssk ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_heat_maps/create_persistence_heat_maps_weighted_by_distance_from_diagonal persistence_heat_maps/create_persistence_heat_maps_weighted_by_distance_from_diagonal.cpp )
-target_link_libraries(persistence_heat_maps/create_persistence_heat_maps_weighted_by_distance_from_diagonal ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_heat_maps/create_persistence_heat_maps_weighted_by_squared_distance_from_diagonal persistence_heat_maps/create_persistence_heat_maps_weighted_by_squared_distance_from_diagonal.cpp )
-target_link_libraries(persistence_heat_maps/create_persistence_heat_maps_weighted_by_squared_distance_from_diagonal ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_heat_maps/create_persistence_heat_maps_weighted_by_arctan_of_their_persistence persistence_heat_maps/create_persistence_heat_maps_weighted_by_arctan_of_their_persistence.cpp )
-target_link_libraries(persistence_heat_maps/create_persistence_heat_maps_weighted_by_arctan_of_their_persistence ${Boost_SYSTEM_LIBRARY})
-
-
-#persitence vectors
-add_executable ( persistence_vectors/average_persistence_vectors persistence_vectors/average_persistence_vectors.cpp )
-target_link_libraries(persistence_vectors/average_persistence_vectors ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_vectors/create_persistence_vectors persistence_vectors/create_persistence_vectors.cpp )
-target_link_libraries(persistence_vectors/create_persistence_vectors ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_vectors/compute_distance_of_persistence_vectors persistence_vectors/compute_distance_of_persistence_vectors.cpp )
-target_link_libraries(persistence_vectors/compute_distance_of_persistence_vectors ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_vectors/compute_scalar_product_of_persistence_vectors persistence_vectors/compute_scalar_product_of_persistence_vectors.cpp )
-target_link_libraries(persistence_vectors/compute_scalar_product_of_persistence_vectors ${Boost_SYSTEM_LIBRARY})
-
-add_executable ( persistence_vectors/plot_persistence_vectors persistence_vectors/plot_persistence_vectors.cpp )
-target_link_libraries(persistence_vectors/plot_persistence_vectors ${Boost_SYSTEM_LIBRARY})
-
-
#some stat libraries:
add_executable ( permutation_test permutation_test.cpp )
target_link_libraries(permutation_test ${Boost_SYSTEM_LIBRARY})
@@ -110,11 +13,11 @@ target_link_libraries(permutation_test ${Boost_SYSTEM_LIBRARY})
#add_executable ( topological_process_2 topological_process_2.cpp )
#target_link_libraries(topological_process_2 ${Boost_SYSTEM_LIBRARY})
-add_executable ( Hausdorff_bootstrap Hausdorff_bootstrap.cpp )
+add_executable ( Hausdorff_subsampling Hausdorff_subsampling.cpp )
if (TBB_FOUND)
-target_link_libraries(Hausdorff_bootstrap ${TBB_LIBRARIES})
+target_link_libraries(Hausdorff_subsampling ${TBB_LIBRARIES})
endif(TBB_FOUND)
-target_link_libraries(Hausdorff_bootstrap ${Boost_SYSTEM_LIBRARY})
+target_link_libraries(Hausdorff_subsampling ${Boost_SYSTEM_LIBRARY})
add_executable ( Landscape_bootstrap Landscape_bootstrap.cpp )
diff --git a/src/Gudhi_stat/utilities/Hausdorff_bootstrap.cpp b/src/Gudhi_stat/utilities/Hausdorff_subsampling.cpp
index 7fd665c3..5556a8ee 100644
--- a/src/Gudhi_stat/utilities/Hausdorff_bootstrap.cpp
+++ b/src/Gudhi_stat/utilities/Hausdorff_subsampling.cpp
@@ -46,13 +46,41 @@ int main( int argc , char** argv )
}
const char* filename = argv[1];
- size_t number_of_repetitions_of_bootstrap = (size_t)atoi( argv[2] );
+ size_t number_of_repetitions_of_subsampling = (size_t)atoi( argv[2] );
size_t size_of_subsample = (size_t)atoi( argv[3] );
double quantile = atof( argv[4] );
- std::cout << "Now we will read points from the file : " << filename << " and then perform " << number_of_repetitions_of_bootstrap << " times the bootstrap on it by choosing subsample of a size " << size_of_subsample << std::endl;
+ std::cout << "Now we will read points from the file : " << filename << " and then perform " << number_of_repetitions_of_subsampling << " times the subsampling on it by choosing subsample of a size " << size_of_subsample << std::endl;
std::vector< std::vector< double > > points = read_numbers_from_file_line_by_line( filename );
+ /*
+ std::vector< std::vector< double > > points;
+ std::vector< double > point1(2);
+ point1[0] = -1;
+ point1[1] = 0;
+ std::vector< double > point2(2);
+ point2[0] = 1;
+ point2[1] = 0;
+ std::vector< double > point3(2);
+ point3[0] = -1;
+ point3[1] = 3;
+ std::vector< double > point4(2);
+ point4[0] = 1;
+ point4[1] = 3;
+ points.push_back( point1 );
+ points.push_back( point2 );
+ points.push_back( point3 );
+ points.push_back( point4 );
+
+
+ std::vector< std::vector<double> > all_to_all_distance_matrix_between_points = compute_all_to_all_distance_matrix_between_points< std::vector<double> , Euclidean_distance<double> >( points );
+ Hausdorff_distance_between_subspace_and_the_whole_metric_space distance( all_to_all_distance_matrix_between_points );
+
+ std::vector<size_t> characteristic_of_all_points = {0,1,2,3};
+ std::vector<size_t> characteristic_of_subsampled_points = {2,3};
+ std::cerr << "DISTANCE BETWEEN SAMPLE AND SUBSAMPLE: " << distance( characteristic_of_subsampled_points , characteristic_of_all_points ) << std::endl;
+ */
+
std::cout << "Read : " << points.size() << " points.\n";
@@ -61,6 +89,11 @@ int main( int argc , char** argv )
Hausdorff_distance_between_subspace_and_the_whole_metric_space distance( all_to_all_distance_matrix_between_points );
identity< std::vector<size_t> > identity_char;
+
+
+
+
+
//and now we can run the real bootstrap.
//template < typename PointCloudCharacteristics , typename CharacteristicFunction , typename DistanceBetweenPointsCharacteristics >
//In this case, the PointCloudCharacteristics is just a vector of numbers of points (in a order fixed on points vector).
@@ -72,9 +105,9 @@ int main( int argc , char** argv )
identity< std::vector<size_t> > , //CharacteristicFunction
Hausdorff_distance_between_subspace_and_the_whole_metric_space //DistanceBetweenPointsCharacteristics. This function have the information about point's coordinates.
>
- ( points.size() , identity_char , distance , number_of_repetitions_of_bootstrap , size_of_subsample , quantile );
+ ( points.size() , identity_char , distance , number_of_repetitions_of_subsampling , size_of_subsample , quantile );
- std::cout << "result of bootstrap : " << result << std::endl;
+ std::cout << "result of the subsampling : " << result << std::endl;
return 0;
diff --git a/src/Gudhi_stat/utilities/persistence_heat_maps/CMakeLists.txt b/src/Gudhi_stat/utilities/persistence_heat_maps/CMakeLists.txt
new file mode 100644
index 00000000..39240db2
--- /dev/null
+++ b/src/Gudhi_stat/utilities/persistence_heat_maps/CMakeLists.txt
@@ -0,0 +1,31 @@
+cmake_minimum_required(VERSION 2.6)
+project(GUDHI_STAT)
+
+#persitence heat maps
+add_executable ( average_persistence_heat_maps average_persistence_heat_maps.cpp )
+target_link_libraries(average_persistence_heat_maps ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( create_persistence_heat_maps create_persistence_heat_maps.cpp )
+target_link_libraries(create_persistence_heat_maps ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( plot_persistence_heat_map plot_persistence_heat_map.cpp )
+target_link_libraries(plot_persistence_heat_map ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_distance_of_persistence_heat_maps compute_distance_of_persistence_heat_maps.cpp )
+target_link_libraries(compute_distance_of_persistence_heat_maps ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_scalar_product_of_persistence_heat_maps compute_scalar_product_of_persistence_heat_maps.cpp )
+target_link_libraries(compute_scalar_product_of_persistence_heat_maps ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( create_pssk create_pssk.cpp )
+target_link_libraries(create_pssk ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( create_persistence_heat_maps_weighted_by_distance_from_diagonal create_persistence_heat_maps_weighted_by_distance_from_diagonal.cpp )
+target_link_libraries(create_persistence_heat_maps_weighted_by_distance_from_diagonal ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( create_persistence_heat_maps_weighted_by_squared_distance_from_diagonal create_persistence_heat_maps_weighted_by_squared_distance_from_diagonal.cpp )
+target_link_libraries(create_persistence_heat_maps_weighted_by_squared_distance_from_diagonal ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( create_persistence_heat_maps_weighted_by_arctan_of_their_persistence create_persistence_heat_maps_weighted_by_arctan_of_their_persistence.cpp )
+target_link_libraries(create_persistence_heat_maps_weighted_by_arctan_of_their_persistence ${Boost_SYSTEM_LIBRARY})
+
diff --git a/src/Gudhi_stat/utilities/persistence_intervals/CMakeLists.txt b/src/Gudhi_stat/utilities/persistence_intervals/CMakeLists.txt
new file mode 100644
index 00000000..96cb1a5e
--- /dev/null
+++ b/src/Gudhi_stat/utilities/persistence_intervals/CMakeLists.txt
@@ -0,0 +1,22 @@
+cmake_minimum_required(VERSION 2.6)
+project(GUDHI_STAT)
+
+
+
+#persitence diagrams
+add_executable ( plot_persistence_intervals plot_persistence_intervals.cpp )
+target_link_libraries( plot_persistence_intervals ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_birth_death_range_in_persistence_diagram compute_birth_death_range_in_persistence_diagram.cpp )
+target_link_libraries( compute_birth_death_range_in_persistence_diagram ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_number_of_dominant_intervals compute_number_of_dominant_intervals.cpp )
+target_link_libraries( compute_number_of_dominant_intervals ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( plot_histogram_of_intervals_lengths plot_histogram_of_intervals_lengths.cpp )
+target_link_libraries( plot_histogram_of_intervals_lengths ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( plot_persistence_Betti_numebrs plot_persistence_Betti_numebrs.cpp )
+target_link_libraries( plot_persistence_Betti_numebrs ${Boost_SYSTEM_LIBRARY})
+
+#when we have bottleneck and wasserstein distance computations, add suitable programs here.
diff --git a/src/Gudhi_stat/utilities/persistence_intervals/plot_persistence_intervals.cpp b/src/Gudhi_stat/utilities/persistence_intervals/plot_persistence_intervals.cpp
index 40f6fbaf..04a05caa 100644
--- a/src/Gudhi_stat/utilities/persistence_intervals/plot_persistence_intervals.cpp
+++ b/src/Gudhi_stat/utilities/persistence_intervals/plot_persistence_intervals.cpp
@@ -44,8 +44,8 @@ int main( int argc , char** argv )
std::cout << "To run this program, please provide the name of a file with persistence diagram \n";
return 1;
}
-
- Persistence_intervals b( argv[1] );
+ std::vector< std::pair< double , double > > intervals = read_gudhi_file( argv[1] , 2 );
+ Persistence_intervals b( intervals );
b.plot( argv[1] );
return 0;
}
diff --git a/src/Gudhi_stat/utilities/persistence_landscapes/CMakeLists.txt b/src/Gudhi_stat/utilities/persistence_landscapes/CMakeLists.txt
new file mode 100644
index 00000000..9caf73f6
--- /dev/null
+++ b/src/Gudhi_stat/utilities/persistence_landscapes/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 2.6)
+project(GUDHI_STAT)
+
+
+
+#persitence landscapes
+add_executable ( average_landscapes average_landscapes.cpp )
+target_link_libraries(average_landscapes ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( create_landscapes create_landscapes.cpp )
+target_link_libraries(create_landscapes ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( plot_landscapes plot_landscapes.cpp )
+target_link_libraries(plot_landscapes ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_distance_of_landscapes compute_distance_of_landscapes.cpp )
+target_link_libraries(compute_distance_of_landscapes ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_scalar_product_of_landscapes compute_scalar_product_of_landscapes.cpp )
+target_link_libraries(compute_scalar_product_of_landscapes ${Boost_SYSTEM_LIBRARY})
+
diff --git a/src/Gudhi_stat/utilities/persistence_landscapes_on_grid/CMakeLists.txt b/src/Gudhi_stat/utilities/persistence_landscapes_on_grid/CMakeLists.txt
new file mode 100644
index 00000000..bb7c3987
--- /dev/null
+++ b/src/Gudhi_stat/utilities/persistence_landscapes_on_grid/CMakeLists.txt
@@ -0,0 +1,22 @@
+cmake_minimum_required(VERSION 2.6)
+project(GUDHI_STAT)
+
+
+
+
+#persitence landscapes on a grid
+add_executable ( average_landscapes_on_grid average_landscapes_on_grid.cpp )
+target_link_libraries(average_landscapes_on_grid ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( create_landscapes_on_grid create_landscapes_on_grid.cpp )
+target_link_libraries(create_landscapes_on_grid ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( plot_landscapes_on_grid plot_landscapes_on_grid.cpp )
+target_link_libraries(plot_landscapes_on_grid ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_distance_of_landscapes_on_grid compute_distance_of_landscapes_on_grid.cpp )
+target_link_libraries(compute_distance_of_landscapes_on_grid ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_scalar_product_of_landscapes_on_grid compute_scalar_product_of_landscapes_on_grid.cpp )
+target_link_libraries(compute_scalar_product_of_landscapes_on_grid ${Boost_SYSTEM_LIBRARY})
+
diff --git a/src/Gudhi_stat/utilities/persistence_vectors/CMakeLists.txt b/src/Gudhi_stat/utilities/persistence_vectors/CMakeLists.txt
new file mode 100644
index 00000000..ebf4898e
--- /dev/null
+++ b/src/Gudhi_stat/utilities/persistence_vectors/CMakeLists.txt
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.6)
+project(GUDHI_STAT)
+
+#persitence vectors
+add_executable ( average_persistence_vectors average_persistence_vectors.cpp )
+target_link_libraries(average_persistence_vectors ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( create_persistence_vectors create_persistence_vectors.cpp )
+target_link_libraries(create_persistence_vectors ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_distance_of_persistence_vectors compute_distance_of_persistence_vectors.cpp )
+target_link_libraries(compute_distance_of_persistence_vectors ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_scalar_product_of_persistence_vectors compute_scalar_product_of_persistence_vectors.cpp )
+target_link_libraries(compute_scalar_product_of_persistence_vectors ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( plot_persistence_vectors plot_persistence_vectors.cpp )
+target_link_libraries(plot_persistence_vectors ${Boost_SYSTEM_LIBRARY})
+
+