summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-11-07 10:30:08 +0000
committermcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-11-07 10:30:08 +0000
commit3d4c842d34f4d6c52ba6c39836f57d702d6a6ff3 (patch)
tree9ca67be2b26fba95049e1f566d2ceee3fbd944ec
parent3182c852e0cfbb772dfe27e30647034d9fa35a32 (diff)
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/Nerve_GIC@2840 636b058d-ea47-450e-bf9e-a15bfbe3eedb
Former-commit-id: 9037e52ab98b2b9c699c104aa4da45bf6d74cfc7
-rw-r--r--CMakeLists.txt3
-rw-r--r--src/CMakeLists.txt1
-rw-r--r--src/Nerve_GIC/doc/Intro_graph_induced_complex.h4
-rw-r--r--src/Nerve_GIC/include/gudhi/GIC.h2
-rw-r--r--src/common/doc/main_page.h10
5 files changed, 10 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da6f5709..ef129cd1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,7 +33,6 @@ endif()
# Add your new module in the list, order is not important
include(GUDHI_modules)
-include_directories(src/Nerve_GIC/include/)
add_gudhi_module(common)
add_gudhi_module(Alpha_complex)
@@ -49,8 +48,8 @@ add_gudhi_module(Spatial_searching)
add_gudhi_module(Subsampling)
add_gudhi_module(Tangential_complex)
add_gudhi_module(Witness_complex)
+add_gudhi_module(Nerve_GIC)
add_subdirectory(src/Nerve_GIC/example)
-add_subdirectory(src/Nerve_GIC/test)
message("++ GUDHI_MODULES list is:\"${GUDHI_MODULES}\"")
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9961fcf9..a2617020 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -24,6 +24,7 @@ add_gudhi_module(Spatial_searching)
add_gudhi_module(Subsampling)
add_gudhi_module(Tangential_complex)
add_gudhi_module(Witness_complex)
+add_gudhi_module(Nerve_GIC)
message("++ GUDHI_MODULES list is:\"${GUDHI_MODULES}\"")
diff --git a/src/Nerve_GIC/doc/Intro_graph_induced_complex.h b/src/Nerve_GIC/doc/Intro_graph_induced_complex.h
index 2a869009..cb9ba554 100644
--- a/src/Nerve_GIC/doc/Intro_graph_induced_complex.h
+++ b/src/Nerve_GIC/doc/Intro_graph_induced_complex.h
@@ -2,9 +2,9 @@
* (Geometric Understanding in Higher Dimensions) is a generic C++
* library for computational topology.
*
- * Author(s): Clément Maria, Pawel Dlotko, Vincent Rouvreau
+ * Author(s): Mathieu Carriere
*
- * Copyright (C) 2016 INRIA
+ * Copyright (C) 2017 INRIA
*
* This program is free software: you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
diff --git a/src/Nerve_GIC/include/gudhi/GIC.h b/src/Nerve_GIC/include/gudhi/GIC.h
index fc615828..2520042d 100644
--- a/src/Nerve_GIC/include/gudhi/GIC.h
+++ b/src/Nerve_GIC/include/gudhi/GIC.h
@@ -700,7 +700,7 @@ class Cover_complex {
* @result cover_back(c) vector of IDs of data points.
*
*/
- std::vector<int> subpopulation(Cover_t c){
+ const std::vector<int> & subpopulation(Cover_t c){
return cover_back[c];
}
diff --git a/src/common/doc/main_page.h b/src/common/doc/main_page.h
index d48294a5..34bf6c22 100644
--- a/src/common/doc/main_page.h
+++ b/src/common/doc/main_page.h
@@ -93,8 +93,8 @@
</td>
</tr>
</table>
- \subsection GICDataStructure Nerves and Graph Induced Complexes
- \image html "gic_complex.png" "Graph Induced Complex of a point cloud."
+ \subsection CoverComplexDataStructure Cover Complexes: Nerves and Graph Induced Complexes
+ \image html "gicvisu.jpg" "Graph Induced Complex of a point cloud."
<table border="0">
<tr>
<td width="25%">
@@ -103,11 +103,11 @@
<b>Copyright:</b> GPL v3<br>
</td>
<td width="75%">
- Nerves and Graph Induced Complexes are simplicial complexes that provably contain
+ Nerves and Graph Induced Complexes are cover complexes, i.e. simplicial complexes that provably contain
topological information about the input data. They can be computed with a cover of the
- data, that often comes from the preimage of a family of intervals covering the image
+ data, that comes i.e. from the preimage of a family of intervals covering the image
of a scalar-valued function defined on the data. <br>
- <b>User manual:</b> \ref graph_induced_complex - <b>Reference manual:</b> Gudhi::graph_induced_complex::Graph_induced_complex
+ <b>User manual:</b> \ref cover_complex - <b>Reference manual:</b> Gudhi::cover_complex::Cover_complex
</td>
</tr>
</table>