summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-08-04 14:12:29 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-08-04 14:12:29 +0200
commit3f566028c076c271865b00d060bd311690a207fe (patch)
tree22ade4bd4576a4d0153f949caa8315268aa12381
parent2b7524879e2c09cd9a197e6b58a7cc31dc5ed056 (diff)
debug pip packaging
-rw-r--r--.github/workflows/pip-packaging-windows.yml21
1 files changed, 13 insertions, 8 deletions
diff --git a/.github/workflows/pip-packaging-windows.yml b/.github/workflows/pip-packaging-windows.yml
index 1cadf6b1..32abd0d2 100644
--- a/.github/workflows/pip-packaging-windows.yml
+++ b/.github/workflows/pip-packaging-windows.yml
@@ -1,8 +1,13 @@
name: pip packaging windows
+#on:
+# release:
+# types: [published]
+
on:
- release:
- types: [published]
+ push:
+ branches:
+ - '*'
jobs:
build:
@@ -22,7 +27,7 @@ jobs:
architecture: x64
- name: Install dependencies
run: |
- vcpkg install boost-graph:x64-windows boost-serialization:x64-windows boost-date-time:x64-windows boost-system:x64-windows boost-filesystem:x64-windows boost-units:x64-windows boost-thread:x64-windows boost-program-options:x64-windows eigen3:x64-windows mpfr:x64-windows mpir:x64-windows cgal:x64-windows
+ vcpkg install boost-graph boost-serialization boost-date-time boost-system boost-filesystem boost-units boost-thread boost-program-options eigen3 mpfr mpir cgal --triplet x64-windows
python -m pip install --user -r .github/build-requirements.txt
python -m pip install --user twine
- name: Build python wheel
@@ -35,8 +40,8 @@ jobs:
cp c:/vcpkg/installed/x64-windows/bin/mpfr.dll gudhi/
cp c:/vcpkg/installed/x64-windows/bin/mpir.dll gudhi/
python setup.py bdist_wheel
- - name: Publish on PyPi
- env:
- TWINE_USERNAME: __token__
- TWINE_PASSWORD: ${{ secrets.PYPI_PASSWORD }}
- run: python -m twine upload build/src/python/dist/*
+# - name: Publish on PyPi
+# env:
+# TWINE_USERNAME: __token__
+# TWINE_PASSWORD: ${{ secrets.PYPI_PASSWORD }}
+# run: python -m twine upload build/src/python/dist/*