summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2023-01-20 17:03:14 +0100
committerGard Spreemann <gspr@nonempty.org>2023-01-26 15:52:46 +0100
commit7be3bc8f1e1e0881d0a33931ff1123497b479739 (patch)
treea4b7497011bea39fbeadfb2674339ad26ad1583e
parent58db7d48d3315d5b4112e2ceaeee8f8c137f9de1 (diff)
Refresh patches, and add patch for Hera 1.0 compatibility
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch101
-rw-r--r--debian/patches/0002-Use-system-MathJax.patch4
-rw-r--r--debian/patches/0003-Offline-header-for-docs.patch4
-rw-r--r--debian/patches/0005-Support-Hera-1.0.patch66
-rw-r--r--debian/patches/0005-Support-QGLViewer-2.7.patch26
-rw-r--r--debian/patches/series2
6 files changed, 107 insertions, 96 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
index d451e683..af6b0afb 100644
--- a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -3,86 +3,57 @@ Date: Wed, 25 Sep 2019 15:12:45 +0200
Subject: Disable tests that use DFSG-deleted data files.
---
- src/Nerve_GIC/example/CMakeLists.txt | 5 -----
- src/Nerve_GIC/utilities/CMakeLists.txt | 8 --------
- src/python/CMakeLists.txt | 29 -----------------------------
- 3 files changed, 42 deletions(-)
+ src/Nerve_GIC/example/CMakeLists.txt | 6 ------
+ src/Nerve_GIC/utilities/CMakeLists.txt | 7 -------
+ src/python/CMakeLists.txt | 3 ---
+ 3 files changed, 16 deletions(-)
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
-index 4b0f467..110212d 100644
+index 9faf1f3..bbfa592 100644
--- a/src/Nerve_GIC/example/CMakeLists.txt
+++ b/src/Nerve_GIC/example/CMakeLists.txt
-@@ -12,14 +12,9 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+@@ -10,12 +10,6 @@ endif()
- # Copy files for not to pollute sources when testing
- file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+-file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+-file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
- add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
- "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
-
-- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
-- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
-- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
-
- endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
+-
+-add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
-index 65a08d9..3f16db9 100644
+index 4521a99..e28973f 100644
--- a/src/Nerve_GIC/utilities/CMakeLists.txt
+++ b/src/Nerve_GIC/utilities/CMakeLists.txt
-@@ -11,14 +11,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
- endif()
+@@ -10,13 +10,6 @@ endif()
- file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- # Copy files for not to pollute sources when testing
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ # Copy files for not to pollute sources when testing
+-file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-
-- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
-- "human.off" "2" "10" "0.3")
+-add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+- "human.off" "2" "10" "0.3")
-
-- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
-- "human.off" "100")
+-add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+- "human.off" "100")
- install(TARGETS Nerve DESTINATION bin)
- install(TARGETS VoronoiGIC DESTINATION bin)
+ install(TARGETS Nerve DESTINATION bin)
+ install(TARGETS VoronoiGIC DESTINATION bin)
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index 5f32393..02082db 100644
+index 39e2acd..b3f2268 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
-@@ -432,35 +432,6 @@ if(PYTHONINTERP_FOUND)
-
- add_gudhi_py_test(test_bottleneck_distance)
-
-- # Cover complex
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- add_test(NAME cover_complex_nerve_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/nerve_of_a_covering.py"
-- -f human.off -c 2 -r 10 -g 0.3)
--
-- add_test(NAME cover_complex_coordinate_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/coordinate_graph_induced_complex.py"
-- -f human.off -c 0 -v)
--
-- add_test(NAME cover_complex_functional_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/functional_graph_induced_complex.py"
-- -o lucky_cat.off
-- -f lucky_cat_PCA1 -v)
--
-- add_test(NAME cover_complex_voronoi_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/voronoi_graph_induced_complex.py"
-- -f human.off -n 700 -v)
--
- add_gudhi_py_test(test_cover_complex)
+@@ -435,9 +435,6 @@ if(PYTHONINTERP_FOUND)
endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ # Cover complex
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ add_test(NAME cover_complex_nerve_example_py_test
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
diff --git a/debian/patches/0002-Use-system-MathJax.patch b/debian/patches/0002-Use-system-MathJax.patch
index 4f8e143c..e5c328ee 100644
--- a/debian/patches/0002-Use-system-MathJax.patch
+++ b/debian/patches/0002-Use-system-MathJax.patch
@@ -7,10 +7,10 @@ Subject: Use system MathJax.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/Doxyfile.in b/src/Doxyfile.in
-index 6e0e033..b2f44d5 100644
+index d5664a4..093aaa5 100644
--- a/src/Doxyfile.in
+++ b/src/Doxyfile.in
-@@ -1506,7 +1506,7 @@ MATHJAX_FORMAT = HTML-CSS
+@@ -1499,7 +1499,7 @@ MATHJAX_FORMAT = HTML-CSS
# The default value is: http://cdn.mathjax.org/mathjax/latest.
# This tag requires that the tag USE_MATHJAX is set to YES.
diff --git a/debian/patches/0003-Offline-header-for-docs.patch b/debian/patches/0003-Offline-header-for-docs.patch
index 2ba471d3..91cad23d 100644
--- a/debian/patches/0003-Offline-header-for-docs.patch
+++ b/debian/patches/0003-Offline-header-for-docs.patch
@@ -7,10 +7,10 @@ Subject: Offline header for docs.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/Doxyfile.in b/src/Doxyfile.in
-index b2f44d5..c938635 100644
+index 093aaa5..152041e 100644
--- a/src/Doxyfile.in
+++ b/src/Doxyfile.in
-@@ -1096,7 +1096,7 @@ HTML_FILE_EXTENSION = .html
+@@ -1095,7 +1095,7 @@ HTML_FILE_EXTENSION = .html
# of the possible markers and block names see the documentation.
# This tag requires that the tag GENERATE_HTML is set to YES.
diff --git a/debian/patches/0005-Support-Hera-1.0.patch b/debian/patches/0005-Support-Hera-1.0.patch
new file mode 100644
index 00000000..de783cb4
--- /dev/null
+++ b/debian/patches/0005-Support-Hera-1.0.patch
@@ -0,0 +1,66 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Fri, 20 Jan 2023 17:02:04 +0100
+Subject: Support Hera 1.0
+
+Upstream GUDHI now expects Hera's headers to be organized as in Hera
+2.0. This patch restores the old behavior until Hera 2.0 is available
+in Debian.
+---
+ src/Nerve_GIC/include/gudhi/GIC.h | 4 ++--
+ src/cmake/modules/GUDHI_submodules.cmake | 2 +-
+ src/python/gudhi/hera/bottleneck.cc | 2 +-
+ src/python/gudhi/hera/wasserstein.cc | 2 +-
+ 4 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/Nerve_GIC/include/gudhi/GIC.h b/src/Nerve_GIC/include/gudhi/GIC.h
+index 047fba6..560f7d6 100644
+--- a/src/Nerve_GIC/include/gudhi/GIC.h
++++ b/src/Nerve_GIC/include/gudhi/GIC.h
+@@ -20,9 +20,9 @@
+ #if __has_include(<CGAL/version.h>)
+ # define GUDHI_GIC_USE_CGAL 1
+ # include <gudhi/Bottleneck.h>
+-#elif __has_include(<hera/bottleneck.h>)
++#elif __has_include(<bottleneck.h>)
+ # define GUDHI_GIC_USE_HERA 1
+-# include <hera/bottleneck.h>
++# include <bottleneck.h>
+ #endif
+
+ #include <gudhi/Debug_utils.h>
+diff --git a/src/cmake/modules/GUDHI_submodules.cmake b/src/cmake/modules/GUDHI_submodules.cmake
+index 9ede852..cec9390 100644
+--- a/src/cmake/modules/GUDHI_submodules.cmake
++++ b/src/cmake/modules/GUDHI_submodules.cmake
+@@ -2,4 +2,4 @@
+ set(HERA_INTERNAL_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/ext/hera/include)
+ set(HERA_INCLUDE_DIR ${HERA_INTERNAL_INCLUDE_DIR} CACHE PATH "Directory where one can find hera/{wasserstein.h,bottleneck.h}")
+ # since everything is cleanly under include/hera/, there is no harm always including it
+-include_directories(${HERA_INCLUDE_DIR})
++include_directories(${HERA_INCLUDE_DIR}/bottleneck ${HERA_INCLUDE_DIR}/wasserstein)
+diff --git a/src/python/gudhi/hera/bottleneck.cc b/src/python/gudhi/hera/bottleneck.cc
+index ec461f7..0cb562c 100644
+--- a/src/python/gudhi/hera/bottleneck.cc
++++ b/src/python/gudhi/hera/bottleneck.cc
+@@ -16,7 +16,7 @@
+ using py::ssize_t;
+ #endif
+
+-#include <hera/bottleneck.h> // Hera
++#include <bottleneck.h> // Hera
+
+ double bottleneck_distance(Dgm d1, Dgm d2, double delta)
+ {
+diff --git a/src/python/gudhi/hera/wasserstein.cc b/src/python/gudhi/hera/wasserstein.cc
+index 3516352..e1bb1d7 100644
+--- a/src/python/gudhi/hera/wasserstein.cc
++++ b/src/python/gudhi/hera/wasserstein.cc
+@@ -16,7 +16,7 @@
+ using py::ssize_t;
+ #endif
+
+-#include <hera/wasserstein.h> // Hera
++#include <wasserstein.h> // Hera
+
+ double wasserstein_distance(
+ Dgm d1, Dgm d2,
diff --git a/debian/patches/0005-Support-QGLViewer-2.7.patch b/debian/patches/0005-Support-QGLViewer-2.7.patch
deleted file mode 100644
index 2f367d5f..00000000
--- a/debian/patches/0005-Support-QGLViewer-2.7.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Mon, 14 Nov 2022 17:28:23 +0100
-Subject: Support QGLViewer >=2.7
-
-This is Marc Glisse's commit 1e71120bdacb6f5ec4c90fb4c1365f76ecea7ff9
-proposed upstream.
----
- src/GudhUI/view/Viewer.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/GudhUI/view/Viewer.cpp b/src/GudhUI/view/Viewer.cpp
-index 6b17c83..2c00f86 100644
---- a/src/GudhUI/view/Viewer.cpp
-+++ b/src/GudhUI/view/Viewer.cpp
-@@ -31,7 +31,11 @@ void Viewer::set_bounding_box(const Point_3 & lower_left, const Point_3 & upper_
- }
-
- void Viewer::update_GL() {
-+#if QGLVIEWER_VERSION >= 0x020700
-+ this->update();
-+#else
- this->updateGL();
-+#endif
- }
-
- void Viewer::init_scene() {
diff --git a/debian/patches/series b/debian/patches/series
index 3f3da71a..0019c6f4 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,4 +2,4 @@
0002-Use-system-MathJax.patch
0003-Offline-header-for-docs.patch
0004-Disable-Sphinx.patch
-0005-Support-QGLViewer-2.7.patch
+0005-Support-Hera-1.0.patch