summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-09-25 15:38:52 +0200
committerGard Spreemann <gspr@nonempty.org>2019-09-25 15:38:52 +0200
commit7e09284bb75e2d4585e0b4572550b1f1aa3f458c (patch)
treea9e410874bac0c1f9e41d7afbfe0c321893b576f
parent232bfbdb5f2ac79492d1dc127d011a0421a7ef15 (diff)
Improve patches.
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch75
-rw-r--r--debian/patches/0007-Disable-Sphinx.patch12
2 files changed, 78 insertions, 9 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
index 973adfc3..82a72911 100644
--- a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -3,9 +3,80 @@ Date: Wed, 25 Sep 2019 15:12:45 +0200
Subject: Disable tests that use DFSG-deleted data files.
---
- src/python/CMakeLists.txt | 31 +------------------------------
- 1 file changed, 1 insertion(+), 30 deletions(-)
+ src/Nerve_GIC/example/CMakeLists.txt | 5 ----
+ src/Nerve_GIC/utilities/CMakeLists.txt | 8 ------
+ src/Persistent_cohomology/example/CMakeLists.txt | 4 ---
+ src/Simplex_tree/example/CMakeLists.txt | 2 --
+ src/python/CMakeLists.txt | 31 +-----------------------
+ 5 files changed, 1 insertion(+), 49 deletions(-)
+diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
+index 1667472..37c4759 100644
+--- a/src/Nerve_GIC/example/CMakeLists.txt
++++ b/src/Nerve_GIC/example/CMakeLists.txt
+@@ -12,15 +12,10 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
+
+- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
+
+ install(TARGETS CoordGIC DESTINATION bin)
+ install(TARGETS FuncGIC DESTINATION bin)
+diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
+index 65a08d9..3f16db9 100644
+--- a/src/Nerve_GIC/utilities/CMakeLists.txt
++++ b/src/Nerve_GIC/utilities/CMakeLists.txt
+@@ -11,14 +11,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ endif()
+
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- # Copy files for not to pollute sources when testing
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+-
+- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+- "human.off" "2" "10" "0.3")
+-
+- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+- "human.off" "100")
+
+ install(TARGETS Nerve DESTINATION bin)
+ install(TARGETS VoronoiGIC DESTINATION bin)
+diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
+index 94ec13c..4a48d21 100644
+--- a/src/Persistent_cohomology/example/CMakeLists.txt
++++ b/src/Persistent_cohomology/example/CMakeLists.txt
+@@ -28,10 +28,6 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
+ add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
+ "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
+-add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
+-add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
+
+ install(TARGETS plain_homology DESTINATION bin)
+ install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
+diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
+index f99b164..ae302dc 100644
+--- a/src/Simplex_tree/example/CMakeLists.txt
++++ b/src/Simplex_tree/example/CMakeLists.txt
+@@ -25,8 +25,6 @@ if(GMP_FOUND AND NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ if (TBB_FOUND)
+ target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
+ endif()
+- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
+- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
+
+ endif()
+
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 5508cbc..1778290 100644
--- a/src/python/CMakeLists.txt
diff --git a/debian/patches/0007-Disable-Sphinx.patch b/debian/patches/0007-Disable-Sphinx.patch
index 146ce560..e3f42382 100644
--- a/debian/patches/0007-Disable-Sphinx.patch
+++ b/debian/patches/0007-Disable-Sphinx.patch
@@ -3,20 +3,18 @@ Date: Wed, 25 Sep 2019 15:28:15 +0200
Subject: Disable Sphinx.
---
- src/cmake/modules/GUDHI_third_party_libraries.cmake | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
+ src/cmake/modules/GUDHI_third_party_libraries.cmake | 1 -
+ 1 file changed, 1 deletion(-)
diff --git a/src/cmake/modules/GUDHI_third_party_libraries.cmake b/src/cmake/modules/GUDHI_third_party_libraries.cmake
-index 360a230..10490ce 100644
+index 360a230..bffd2ee 100644
--- a/src/cmake/modules/GUDHI_third_party_libraries.cmake
+++ b/src/cmake/modules/GUDHI_third_party_libraries.cmake
-@@ -123,8 +123,7 @@ if( PYTHONINTERP_FOUND )
- find_python_module("pytest")
+@@ -124,7 +124,6 @@ if( PYTHONINTERP_FOUND )
find_python_module("matplotlib")
find_python_module("numpy")
-- find_python_module("scipy")
+ find_python_module("scipy")
- find_python_module("sphinx")
-+ find_python_module("scipy")
endif()
if(NOT GUDHI_PYTHON_PATH)