summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHind-M <hind.montassif@gmail.com>2021-09-27 15:19:25 +0200
committerHind-M <hind.montassif@gmail.com>2021-09-27 15:19:25 +0200
commit8749199e00c0ed1c32b8e0198a65797de3ad192a (patch)
tree87d40db04e7bfb363913aa7fd13c3bfed11b0a85
parent82524c5b0a6ab02b020574b2200a8721f3ed424c (diff)
Add option in cmake to enable or not the inclusion of datasets fetching test (disabled by default)
-rw-r--r--src/cmake/modules/GUDHI_modules.cmake11
-rw-r--r--src/python/CMakeLists.txt4
2 files changed, 9 insertions, 6 deletions
diff --git a/src/cmake/modules/GUDHI_modules.cmake b/src/cmake/modules/GUDHI_modules.cmake
index ccaf1ac5..9cc1a8f5 100644
--- a/src/cmake/modules/GUDHI_modules.cmake
+++ b/src/cmake/modules/GUDHI_modules.cmake
@@ -17,11 +17,12 @@ function(add_gudhi_module file_path)
endfunction(add_gudhi_module)
-option(WITH_GUDHI_BENCHMARK "Activate/desactivate benchmark compilation" OFF)
-option(WITH_GUDHI_EXAMPLE "Activate/desactivate examples compilation and installation" OFF)
-option(WITH_GUDHI_PYTHON "Activate/desactivate python module compilation and installation" ON)
-option(WITH_GUDHI_TEST "Activate/desactivate examples compilation and installation" ON)
-option(WITH_GUDHI_UTILITIES "Activate/desactivate utilities compilation and installation" ON)
+option(WITH_GUDHI_BENCHMARK "Activate/deactivate benchmark compilation" OFF)
+option(WITH_GUDHI_EXAMPLE "Activate/deactivate examples compilation and installation" OFF)
+option(WITH_NETWORK "Activate/deactivate datasets fetching test which uses the Internet" OFF)
+option(WITH_GUDHI_PYTHON "Activate/deactivate python module compilation and installation" ON)
+option(WITH_GUDHI_TEST "Activate/deactivate examples compilation and installation" ON)
+option(WITH_GUDHI_UTILITIES "Activate/deactivate utilities compilation and installation" ON)
if (WITH_GUDHI_BENCHMARK)
set(GUDHI_SUB_DIRECTORIES "${GUDHI_SUB_DIRECTORIES};benchmark")
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 6f117588..6c8dfe32 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -543,7 +543,9 @@ if(PYTHONINTERP_FOUND)
endif()
# Fetch remote datasets
- add_gudhi_py_test(test_remote_datasets)
+ if(WITH_NETWORK)
+ add_gudhi_py_test(test_remote_datasets)
+ endif()
# Set missing or not modules
set(GUDHI_MODULES ${GUDHI_MODULES} "python" CACHE INTERNAL "GUDHI_MODULES")